summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-06 15:18:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-06 15:18:00 +0000
commit48958b61c68c7bdfab11f822b82feed3f8faba0b (patch)
tree41163046030fdf748d308eeefafc3fcb7bbfd5f1 /dev-ml
parentRebase the future -198 build split patch on current git HEAD. Requested in bu... (diff)
downloadgentoo-2-48958b61c68c7bdfab11f822b82feed3f8faba0b.tar.gz
gentoo-2-48958b61c68c7bdfab11f822b82feed3f8faba0b.tar.bz2
gentoo-2-48958b61c68c7bdfab11f822b82feed3f8faba0b.zip
eapi5: define subslot, use slot deps and remove useless || die
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ulex/ChangeLog7
-rw-r--r--dev-ml/ulex/ulex-1.1.ebuild16
2 files changed, 13 insertions, 10 deletions
diff --git a/dev-ml/ulex/ChangeLog b/dev-ml/ulex/ChangeLog
index 9ed68cff37d3..3f7116b8555a 100644
--- a/dev-ml/ulex/ChangeLog
+++ b/dev-ml/ulex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ulex
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ChangeLog,v 1.20 2009/11/25 09:40:08 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ChangeLog,v 1.21 2013/03/06 15:18:00 aballier Exp $
+
+ 06 Mar 2013; Alexis Ballier <aballier@gentoo.org> ulex-1.1.ebuild:
+ eapi5: define subslot, use slot deps and remove useless || die
25 Nov 2009; Markus Meier <maekke@gentoo.org> ulex-1.1.ebuild:
amd64 stable, bug #280418
diff --git a/dev-ml/ulex/ulex-1.1.ebuild b/dev-ml/ulex/ulex-1.1.ebuild
index 709f3b91bcb6..8b37cff4d53b 100644
--- a/dev-ml/ulex/ulex-1.1.ebuild
+++ b/dev-ml/ulex/ulex-1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ulex-1.1.ebuild,v 1.5 2009/11/25 09:40:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ulex-1.1.ebuild,v 1.6 2013/03/06 15:18:00 aballier Exp $
-EAPI="2"
+EAPI="5"
inherit eutils findlib
@@ -11,20 +11,20 @@ HOMEPAGE="http://www.cduce.org"
SRC_URI="http://www.cduce.org/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="amd64 ppc x86"
IUSE="+ocamlopt"
-DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
src_compile() {
- emake all || die "failed to build bytecode"
+ emake all
if use ocamlopt; then
- emake all.opt || die "failed to build native code"
+ emake all.opt
fi
}
src_install() {
findlib_src_install
- dodoc README CHANGES || die
+ dodoc README CHANGES
}