summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-25 18:56:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-25 18:56:12 +0000
commit32c5156674911c3b75102aea0b5f1df625a437ca (patch)
tree7288b50cce98e193045d474ae0d9faba29f13258 /dev-ml
parentalpha/sparc stable wrt #369897 (diff)
downloadgentoo-2-32c5156674911c3b75102aea0b5f1df625a437ca.tar.gz
gentoo-2-32c5156674911c3b75102aea0b5f1df625a437ca.tar.bz2
gentoo-2-32c5156674911c3b75102aea0b5f1df625a437ca.zip
version bump, by Vladimir Ivanov, bug #361165
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/bin-prot/ChangeLog7
-rw-r--r--dev-ml/bin-prot/bin-prot-1.3.1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
index 769e2f111440..2f2dd4dd6fe7 100644
--- a/dev-ml/bin-prot/ChangeLog
+++ b/dev-ml/bin-prot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/bin-prot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.8 2011/02/22 15:10:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.9 2011/06/25 18:56:12 aballier Exp $
+
+*bin-prot-1.3.1 (25 Jun 2011)
+
+ 25 Jun 2011; Alexis Ballier <aballier@gentoo.org> +bin-prot-1.3.1.ebuild:
+ version bump, by Vladimir Ivanov, bug #361165
*bin-prot-1.3.0 (22 Feb 2011)
diff --git a/dev-ml/bin-prot/bin-prot-1.3.1.ebuild b/dev-ml/bin-prot/bin-prot-1.3.1.ebuild
new file mode 100644
index 000000000000..efb458398913
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-1.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-1.3.1.ebuild,v 1.1 2011/06/25 18:56:12 aballier Exp $
+
+EAPI=3
+
+EAPI="2"
+
+inherit findlib eutils multilib
+
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://www.janestreet.com/ocaml/bin_prot-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ dev-ml/findlib
+ >=dev-ml/ounit-1.0.2
+ >=dev-ml/type-conv-2.3.0"
+DEPEND="${RDEPEND}
+ >=dev-ml/ounit-1.0.2
+ doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
+
+S=${WORKDIR}/bin_prot-${PV}
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README Changelog || die
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}