summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-21 13:26:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-21 13:26:02 +0000
commit08792b91c5437d4b24b4151bf531cc8f6a94fa5c (patch)
tree4b2c10d39ff697aef02c1891e6ac1bb857326b85 /dev-ml
parentVersion bump (diff)
downloadgentoo-2-08792b91c5437d4b24b4151bf531cc8f6a94fa5c.tar.gz
gentoo-2-08792b91c5437d4b24b4151bf531cc8f6a94fa5c.tar.bz2
gentoo-2-08792b91c5437d4b24b4151bf531cc8f6a94fa5c.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocurl/ChangeLog8
-rw-r--r--dev-ml/ocurl/files/ocurl-0.5.1-asneeded.patch28
-rw-r--r--dev-ml/ocurl/ocurl-0.5.1.ebuild45
3 files changed, 80 insertions, 1 deletions
diff --git a/dev-ml/ocurl/ChangeLog b/dev-ml/ocurl/ChangeLog
index dca2647d36b2..9462c3984e5f 100644
--- a/dev-ml/ocurl/ChangeLog
+++ b/dev-ml/ocurl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocurl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.7 2009/06/21 13:10:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.8 2009/06/21 13:26:01 aballier Exp $
+
+*ocurl-0.5.1 (21 Jun 2009)
+
+ 21 Jun 2009; Alexis Ballier <aballier@gentoo.org> +ocurl-0.5.1.ebuild,
+ +files/ocurl-0.5.1-asneeded.patch:
+ version bump
21 Jun 2009; Alexis Ballier <aballier@gentoo.org> ocurl-0.2.1.ebuild:
dont install copying
diff --git a/dev-ml/ocurl/files/ocurl-0.5.1-asneeded.patch b/dev-ml/ocurl/files/ocurl-0.5.1-asneeded.patch
new file mode 100644
index 000000000000..d74dc0e61aae
--- /dev/null
+++ b/dev-ml/ocurl/files/ocurl-0.5.1-asneeded.patch
@@ -0,0 +1,28 @@
+Index: ocurl/Makefile.in
+===================================================================
+--- ocurl.orig/Makefile.in
++++ ocurl/Makefile.in
+@@ -27,7 +27,7 @@ CURLHELPEROBJS = curl-helper.o
+ CURLOBJS = curl.cmx
+ CURLBCOBJS = $(CURLOBJS:.cmx=.cmo)
+
+-CURLFLAGS = -ccopt @CURLFLAGS@
++CURLFLAGS = -ccopt "-I. @CURLFLAGS@"
+ CURLCLIBS = -cclib -lcurl-helper -cclib "@CURLLIBS@"
+
+ ifeq (@OCAMLBEST@,opt)
+Index: ocurl/configure.in
+===================================================================
+--- ocurl.orig/configure.in
++++ ocurl/configure.in
+@@ -5,8 +5,8 @@ dnl
+ AC_INIT(curl.ml)
+
+ CURLDIR=`curl-config --cflags`
+-CURLFLAGS=`curl-config --libs | cut -d ' ' -f 1`
+-CURLLIBS=`curl-config --libs | cut -d ' ' -f 2-`
++CURLFLAGS=`curl-config --cflags`
++CURLLIBS=`curl-config --libs`
+
+ CFLAGS=$CURLDIR
+
diff --git a/dev-ml/ocurl/ocurl-0.5.1.ebuild b/dev-ml/ocurl/ocurl-0.5.1.ebuild
new file mode 100644
index 000000000000..8325fa0e95ee
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.5.1.ebuild,v 1.1 2009/06/21 13:26:01 aballier Exp $
+
+EAPI=2
+
+inherit eutils findlib autotools
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://sourceforge.net/projects/ocurl"
+LICENSE="MIT"
+SRC_URI="mirror://sourceforge/ocurl/${P}.tgz"
+
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=net-misc/curl-7.9.8
+dev-libs/openssl"
+RDEPEND="$DEPEND"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-findlib
+}
+
+src_compile()
+{
+ emake -j1 all || die
+}
+
+src_install()
+{
+ findlib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}