summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-06-20 00:56:43 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-06-20 00:56:43 +0000
commit028ea527cc92ca3aa03e6784a254c5b976477196 (patch)
tree2a69a8f43fa9bfdef83b677d3ca792350b46530a /dev-ml
parentManifest (duh) (diff)
downloadgentoo-2-028ea527cc92ca3aa03e6784a254c5b976477196.tar.gz
gentoo-2-028ea527cc92ca3aa03e6784a254c5b976477196.tar.bz2
gentoo-2-028ea527cc92ca3aa03e6784a254c5b976477196.zip
version update
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/Manifest6
-rw-r--r--dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.03.31
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-5.03.3.ebuild35
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-ml/pcre-ocaml/Manifest b/dev-ml/pcre-ocaml/Manifest
index f8d26bce589b..f333263500b9 100644
--- a/dev-ml/pcre-ocaml/Manifest
+++ b/dev-ml/pcre-ocaml/Manifest
@@ -1,5 +1,7 @@
-MD5 e6b2b8d992f239a8404239db551fc6aa ChangeLog 703
-MD5 136641a26464bc4b5c7b552f29a8361a pcre-ocaml-4.26.3.ebuild 827
MD5 8c1b893b9f0ed32e4c85f4adbeb702f6 pcre-ocaml-4.33.0.ebuild 906
+MD5 136641a26464bc4b5c7b552f29a8361a pcre-ocaml-4.26.3.ebuild 827
+MD5 e6b2b8d992f239a8404239db551fc6aa ChangeLog 703
+MD5 32c67c77a9a396590ad29faba1f1b518 pcre-ocaml-5.03.3.ebuild 907
MD5 aec41ffe97cf9b0cd7d6dea307de5aaa files/digest-pcre-ocaml-4.26.3 69
MD5 470fb9405cf453447cc8d6d579bec3c6 files/digest-pcre-ocaml-4.33.0 69
+MD5 59cbe47e1fe7bd32f076d946721a9581 files/digest-pcre-ocaml-5.03.3 69
diff --git a/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.03.3 b/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.03.3
new file mode 100644
index 000000000000..7c29cc925dae
--- /dev/null
+++ b/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.03.3
@@ -0,0 +1 @@
+MD5 22769e475f6750119adc8f6314887a45 pcre-ocaml-5.03.3.tar.bz2 43363
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-5.03.3.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-5.03.3.ebuild
new file mode 100644
index 000000000000..e0222060de9f
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-5.03.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-5.03.3.ebuild,v 1.1 2003/06/20 00:56:31 george Exp $
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.06-r1
+ >=dev-libs/libpcre-4.2-r1
+ >=dev-ml/findlib-0.8"
+
+SRC_URI="http://www.oefai.at/~markus/ocaml_sources/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+SLOT="3"
+KEYWORDS="~x86"
+IUSE=""
+
+src_compile() {
+ emake all || die
+}
+
+src_install () {
+ # which directory does the lib go into?
+ destdir=`ocamlfind printconf destdir`
+
+ # install
+ mkdir -p ${D}${destdir} || die
+ make OCAMLFIND_DESTDIR=${D}${destdir} \
+ OCAMLFIND_LDCONF=dummy install || die
+
+ # install documentation
+ dodoc LICENSE README VERSION
+}