summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-27 21:03:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-27 21:03:58 +0000
commitcabd75bd0e06b35c6f00de63f12b677a0d741ae7 (patch)
tree0177352d18417f7ebca851861d4496700ca65d60 /dev-ml/react
parentadd oasis.eclass (diff)
downloadgentoo-2-cabd75bd0e06b35c6f00de63f12b677a0d741ae7.tar.gz
gentoo-2-cabd75bd0e06b35c6f00de63f12b677a0d741ae7.tar.bz2
gentoo-2-cabd75bd0e06b35c6f00de63f12b677a0d741ae7.zip
convert to oasis.eclass
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/react')
-rw-r--r--dev-ml/react/ChangeLog5
-rw-r--r--dev-ml/react/react-0.9.3.ebuild36
2 files changed, 11 insertions, 30 deletions
diff --git a/dev-ml/react/ChangeLog b/dev-ml/react/ChangeLog
index 53637d2d4f2c..88b6ed15ee0b 100644
--- a/dev-ml/react/ChangeLog
+++ b/dev-ml/react/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/react
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/react/ChangeLog,v 1.6 2012/03/18 16:22:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/react/ChangeLog,v 1.7 2012/03/27 21:03:58 aballier Exp $
+
+ 27 Mar 2012; Alexis Ballier <aballier@gentoo.org> react-0.9.3.ebuild:
+ convert to oasis.eclass
*react-0.9.3 (18 Mar 2012)
diff --git a/dev-ml/react/react-0.9.3.ebuild b/dev-ml/react/react-0.9.3.ebuild
index e760941c0741..6889d4b1300a 100644
--- a/dev-ml/react/react-0.9.3.ebuild
+++ b/dev-ml/react/react-0.9.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/react/react-0.9.3.ebuild,v 1.1 2012/03/18 16:22:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/react/react-0.9.3.ebuild,v 1.2 2012/03/27 21:03:58 aballier Exp $
EAPI="4"
-inherit multilib findlib
+inherit oasis
DESCRIPTION="OCaml module for functional reactive programming"
HOMEPAGE="http://erratique.ch/software/react"
@@ -13,36 +13,14 @@ SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="+ocamlopt debug test"
+IUSE="test"
-DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]"
+DEPEND=""
RDEPEND="${DEPEND}"
-oasis_use_enable() {
- echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
-}
+DOCS=( "CHANGES" "README" )
src_configure() {
- ocaml setup.ml -configure \
- --prefix usr \
- --libdir /usr/$(get_libdir) \
- --destdir "${D}" \
- $(oasis_use_enable debug debug) \
- $(oasis_use_enable ocamlopt is_native) \
- $(use_enable test tests) \
- || die
-}
-
-src_compile() {
- ocaml setup.ml -build || die
-}
-
-src_test() {
- ocaml setup.ml -test || die
-}
-
-src_install() {
- findlib_src_preinst
- ocaml setup.ml -install || die
- dodoc CHANGES README
+ oasis_configure_opts="$(use_enable test tests)" \
+ oasis_src_configure
}