summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-08-23 08:50:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-08-23 08:50:31 +0000
commit8de0324866d3bb43d670e9bf07a7049d66d7a167 (patch)
tree5537dd761434cc07a2477c8180bf78156fc949c5 /dev-ml/pcre-ocaml
parentUse empty ant classpath so asm doesn't get pulled in there and break building... (diff)
downloadgentoo-2-8de0324866d3bb43d670e9bf07a7049d66d7a167.tar.gz
gentoo-2-8de0324866d3bb43d670e9bf07a7049d66d7a167.tar.bz2
gentoo-2-8de0324866d3bb43d670e9bf07a7049d66d7a167.zip
version bump, bug #119114
(Portage version: 2.1.3.6)
Diffstat (limited to 'dev-ml/pcre-ocaml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog8
-rw-r--r--dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.12.13
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-5.12.1.ebuild31
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index df684f4980cd..01d8ccf3936a 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.12 2007/02/09 07:37:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.13 2007/08/23 08:50:31 aballier Exp $
+
+*pcre-ocaml-5.12.1 (23 Aug 2007)
+
+ 23 Aug 2007; Alexis Ballier <aballier@gentoo.org>
+ +pcre-ocaml-5.12.1.ebuild:
+ version bump, bug #119114
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.12.1 b/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.12.1
new file mode 100644
index 000000000000..0a2092ebb60a
--- /dev/null
+++ b/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.12.1
@@ -0,0 +1,3 @@
+MD5 f09e55a461eed349acc9e89216137cef pcre-ocaml-5.12.1.tar.bz2 50046
+RMD160 e8303be6c4e499a299b86e59584049a27ca15b54 pcre-ocaml-5.12.1.tar.bz2 50046
+SHA256 5e2855cdabfc322673fdca3d6ee356889b13d9842e277c9435891194df7404ff pcre-ocaml-5.12.1.tar.bz2 50046
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-5.12.1.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-5.12.1.ebuild
new file mode 100644
index 000000000000..914fc02d8863
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-5.12.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-5.12.1.ebuild,v 1.1 2007/08/23 08:50:31 aballier Exp $
+
+inherit findlib
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.07
+ >=dev-libs/libpcre-4.5"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README VERSION Changes
+
+ if use examples; then
+ for dir in examples/*
+ do
+ docinto $dir
+ dodoc $dir/*
+ done
+ fi
+}