summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-28 17:01:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-28 17:01:06 +0000
commit42439ee0899b7b41efb2c67767ce39d2b1945817 (patch)
treef60e4f6f6fd8c5358f3ef1d1c40f3ce7229c18c7 /dev-ml/ocamlnet
parentFix handling of frameworks version dependencies within kde-frameworks. (diff)
downloadgentoo-2-42439ee0899b7b41efb2c67767ce39d2b1945817.tar.gz
gentoo-2-42439ee0899b7b41efb2c67767ce39d2b1945817.tar.bz2
gentoo-2-42439ee0899b7b41efb2c67767ce39d2b1945817.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog7
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 4770d526266f..4f68e607c392 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.82 2014/03/13 20:39:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.83 2014/10/28 17:01:06 aballier Exp $
+
+*ocamlnet-3.7.7 (28 Oct 2014)
+
+ 28 Oct 2014; Alexis Ballier <aballier@gentoo.org> +ocamlnet-3.7.7.ebuild:
+ version bump
13 Mar 2014; Alexis Ballier <aballier@gentoo.org> -ocamlnet-3.6.3.ebuild,
-ocamlnet-3.6.5.ebuild, -ocamlnet-3.6.6.ebuild,
diff --git a/dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild b/dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild
new file mode 100644
index 000000000000..7a7fb7106887
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild,v 1.1 2014/10/28 17:01:06 aballier Exp $
+
+EAPI="5"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="ZLIB GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5:= )
+ >=dev-lang/ocaml-3.10.2:=[tk?,ocamlopt?]
+ cryptokit? ( dev-ml/cryptokit:= )
+ gtk? ( >=dev-ml/lablgtk-2:= )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4:= )
+ zip? ( dev-ml/camlzip:= )
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable cryptokit crypto) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}