summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-02 10:49:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-02 10:49:29 +0000
commit379a03bf843736536f02e5a9d9ce01ec05cdef5f (patch)
treeedbcde24f654b329400b97166b65e6a02e595b2f /dev-ml/ocamlnet
parentversion bump (diff)
downloadgentoo-2-379a03bf843736536f02e5a9d9ce01ec05cdef5f.tar.gz
gentoo-2-379a03bf843736536f02e5a9d9ce01ec05cdef5f.tar.bz2
gentoo-2-379a03bf843736536f02e5a9d9ce01ec05cdef5f.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog7
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.0.2.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 5e9bd615f8f1..93b9efab2b1b 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.88 2015/02/25 15:35:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.89 2015/03/02 10:49:29 aballier Exp $
+
+*ocamlnet-4.0.2 (02 Mar 2015)
+
+ 02 Mar 2015; Alexis Ballier <aballier@gentoo.org> +ocamlnet-4.0.2.ebuild:
+ version bump
25 Feb 2015; Agostino Sarubbo <ago@gentoo.org> ocamlnet-3.7.7.ebuild:
Stable for x86, wrt bug #535130
diff --git a/dev-ml/ocamlnet/ocamlnet-4.0.2.ebuild b/dev-ml/ocamlnet/ocamlnet-4.0.2.ebuild
new file mode 100644
index 000000000000..794e71f9fded
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-4.0.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-4.0.2.ebuild,v 1.1 2015/03/02 10:49:29 aballier Exp $
+
+EAPI="5"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="ZLIB GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+RDEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5:= )
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ tk? ( || ( dev-ml/labltk:= <dev-lang/ocaml-4.02[tk] ) )
+ ssl? ( net-libs/gnutls:= )
+ gtk? ( >=dev-ml/lablgtk-2:= )
+ kerberos? ( virtual/krb5 )
+ zip? ( dev-ml/camlzip:= )
+ "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable ssl gnutls) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable kerberos gssapi) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}