summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-18 21:43:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-18 21:43:45 +0000
commit9f9c7b716db7e9d16c70e0c78c83f555e3af45f5 (patch)
treef8b606577ec9cccc4159ae5465daf3761a720f71 /dev-ml/ocamlduce
parentversion bump (diff)
downloadgentoo-2-9f9c7b716db7e9d16c70e0c78c83f555e3af45f5.tar.gz
gentoo-2-9f9c7b716db7e9d16c70e0c78c83f555e3af45f5.tar.bz2
gentoo-2-9f9c7b716db7e9d16c70e0c78c83f555e3af45f5.zip
version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlduce')
-rw-r--r--dev-ml/ocamlduce/ChangeLog8
-rw-r--r--dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-ml/ocamlduce/ChangeLog b/dev-ml/ocamlduce/ChangeLog
index 1f10bb7bdb57..68958b1d683a 100644
--- a/dev-ml/ocamlduce/ChangeLog
+++ b/dev-ml/ocamlduce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlduce
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.10 2009/06/20 15:17:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.11 2009/09/18 21:43:45 aballier Exp $
+
+*ocamlduce-3.11.1.0 (18 Sep 2009)
+
+ 18 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ +ocamlduce-3.11.1.0.ebuild:
+ version bump
20 Jun 2009; Alexis Ballier <aballier@gentoo.org> ocamlduce-3.10.2.ebuild:
define eapi before inherit
diff --git a/dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild b/dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild
new file mode 100644
index 000000000000..3587aaa543b7
--- /dev/null
+++ b/dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild,v 1.1 2009/09/18 21:43:45 aballier Exp $
+
+EAPI="2"
+
+inherit versionator eutils toolchain-funcs flag-o-matic multilib
+
+OCAML_VERSION=3.11.1
+OCAML_TARBALL=ocaml-${OCAML_VERSION}.tar.bz2
+OCAML_PATCHLEVEL=1
+OCAML_GENTOO_PATCHES=ocaml-patches-${OCAML_PATCHLEVEL}.tar.bz2
+
+DESCRIPTION="OCamlDuce is a merger between OCaml and CDuce"
+HOMEPAGE="http://ocamlduce.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/225/${P}.tar.gz
+ ftp://ftp.inria.fr/INRIA/cristal/ocaml/ocaml-$(get_version_component_range 1-2 ${OCAML_VERSION})/${OCAML_TARBALL}
+ mirror://gentoo/${OCAML_GENTOO_PATCHES}"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+ocamlopt"
+
+DEPEND="~dev-lang/ocaml-${OCAML_VERSION}[ocamlopt?]
+ >=dev-ml/findlib-1.1.2"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}/ocaml-${OCAML_VERSION}
+
+src_unpack() {
+ unpack ${P}.tar.gz ${OCAML_GENTOO_PATCHES}
+}
+
+src_prepare() {
+ cd "${WORKDIR}/${P}"
+ emake OCAML_SOURCE="${DISTDIR}/${OCAML_TARBALL}" prepare || die "failed to prepare"
+ cd "${S}"
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+}
+
+src_configure() {
+ RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/ocaml \
+ --mandir /usr/share/man \
+ -host "${CHOST}" \
+ -cc "$(tc-getCC)" \
+ -as "$(tc-getAS)" \
+ -aspp "$(tc-getCC) -c" \
+ --with-pthread || die "configure failed!"
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake -f Makefile.ocamlduce -j1 world.opt || die
+ else
+ emake -f Makefile.ocamlduce -j1 world || die
+ fi
+}
+
+src_install() {
+ emake -f Makefile.ocamlduce BINDIR="${D}/usr/bin" LIBDIR="${D}/usr/$(get_libdir)/ocaml" installbyte || die
+ if use ocamlopt; then
+ emake -f Makefile.ocamlduce BINDIR="${D}/usr/bin" LIBDIR="${D}/usr/$(get_libdir)/ocaml" installopt || die
+ fi
+ dosym /usr/$(get_libdir)/ocaml/${PN} /usr/$(get_libdir)/ocaml/site-packages/${PN}
+ dodoc Changes README
+}