summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-03 23:24:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-03 23:24:17 +0000
commit66a5eb33fa410cbd7ed49cfca779bf4a3c63273d (patch)
tree5f983975a2de2bb74d8d0ade4d3768564e0e55cd /dev-ml/ocaml-mysql
parentVersion bump (bug #203806). Cleanup. (diff)
downloadgentoo-2-66a5eb33fa410cbd7ed49cfca779bf4a3c63273d.tar.gz
gentoo-2-66a5eb33fa410cbd7ed49cfca779bf4a3c63273d.tar.bz2
gentoo-2-66a5eb33fa410cbd7ed49cfca779bf4a3c63273d.zip
version bump, make ocamlopt optional, ~amd64
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml/ocaml-mysql')
-rw-r--r--dev-ml/ocaml-mysql/ChangeLog10
-rw-r--r--dev-ml/ocaml-mysql/files/digest-ocaml-mysql-1.0.43
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild57
3 files changed, 68 insertions, 2 deletions
diff --git a/dev-ml/ocaml-mysql/ChangeLog b/dev-ml/ocaml-mysql/ChangeLog
index 86d14227bd63..43b6b6fa7a20 100644
--- a/dev-ml/ocaml-mysql/ChangeLog
+++ b/dev-ml/ocaml-mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-mysql
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.5 2006/11/23 17:14:59 vivo Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.6 2008/01/03 23:24:17 aballier Exp $
+
+*ocaml-mysql-1.0.4 (03 Jan 2008)
+
+ 03 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-mysql-1.0.4.ebuild:
+ version bump, make ocamlopt optional, ~amd64
23 Nov 2006; Francesco Riosa <vivo@gentoo.org>
ocaml-mysql-1.0.3-r1.ebuild:
diff --git a/dev-ml/ocaml-mysql/files/digest-ocaml-mysql-1.0.4 b/dev-ml/ocaml-mysql/files/digest-ocaml-mysql-1.0.4
new file mode 100644
index 000000000000..1e861035272a
--- /dev/null
+++ b/dev-ml/ocaml-mysql/files/digest-ocaml-mysql-1.0.4
@@ -0,0 +1,3 @@
+MD5 76f1282bb7299012669bf40cde78216b ocaml-mysql-1.0.4.tar.gz 119584
+RMD160 57b316fdbdd26762916859d04ab0ca15c1365203 ocaml-mysql-1.0.4.tar.gz 119584
+SHA256 59d11111558986f0ed237016f9758a3cb99e2fdd0ce0dc128319a3ac2a55259e ocaml-mysql-1.0.4.tar.gz 119584
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild
new file mode 100644
index 000000000000..f62ee0e4d90f
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild,v 1.1 2008/01/03 23:24:17 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases."
+SRC_URI="http://raevnos.pennmush.org/code/${PN}/${P}.tar.gz"
+HOMEPAGE="http://raevnos.pennmush.org/code/ocaml-mysql/index.html"
+
+DEPEND=">=dev-lang/ocaml-3.06
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.3-head.patch"
+ epatch "${FILESDIR}/${PN}-1.0.3-shtool-r1.patch"
+}
+
+src_compile()
+{
+ econf
+ emake all || die "make failed"
+ if use ocamlopt; then
+ emake opt || die "make opt failed"
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install || die "make install failed"
+
+ use doc && dohtml -r doc/html/*
+ dodoc CHANGES README VERSION
+}