summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-22 16:13:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-22 16:13:07 +0000
commit35d59fea02043ed03094aa536f2bb440dfa6fa67 (patch)
tree53d4a43e60787873dc9dfc364f5ba03d3ee9e247 /dev-ml/ocaml-expect
parentVersion bump. Remove old. (diff)
downloadgentoo-2-35d59fea02043ed03094aa536f2bb440dfa6fa67.tar.gz
gentoo-2-35d59fea02043ed03094aa536f2bb440dfa6fa67.tar.bz2
gentoo-2-35d59fea02043ed03094aa536f2bb440dfa6fa67.zip
Initial import, ebuild by Vladimir Ivanov <v.ivanov@ymail.com>, bug #355763, with improvements by me.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocaml-expect')
-rw-r--r--dev-ml/ocaml-expect/ChangeLog11
-rw-r--r--dev-ml/ocaml-expect/metadata.xml9
-rw-r--r--dev-ml/ocaml-expect/ocaml-expect-0.0.2.ebuild52
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expect/ChangeLog b/dev-ml/ocaml-expect/ChangeLog
new file mode 100644
index 000000000000..b86968de6114
--- /dev/null
+++ b/dev-ml/ocaml-expect/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocaml-expect
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expect/ChangeLog,v 1.1 2011/02/22 16:13:07 aballier Exp $
+
+*ocaml-expect-0.0.2 (22 Feb 2011)
+
+ 22 Feb 2011; Alexis Ballier <aballier@gentoo.org> +ocaml-expect-0.0.2.ebuild,
+ +metadata.xml:
+ Initial import, ebuild by Vladimir Ivanov <v.ivanov@ymail.com>, bug #355763,
+ with improvements by me.
+
diff --git a/dev-ml/ocaml-expect/metadata.xml b/dev-ml/ocaml-expect/metadata.xml
new file mode 100644
index 000000000000..f6b3ee22be88
--- /dev/null
+++ b/dev-ml/ocaml-expect/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+<maintainer>
+ <email>v.ivanov@ymail.com</email>
+ <name>Vladimir Ivanov</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-expect/ocaml-expect-0.0.2.ebuild b/dev-ml/ocaml-expect/ocaml-expect-0.0.2.ebuild
new file mode 100644
index 000000000000..819fb184246c
--- /dev/null
+++ b/dev-ml/ocaml-expect/ocaml-expect-0.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expect/ocaml-expect-0.0.2.ebuild,v 1.1 2011/02/22 16:13:07 aballier Exp $
+
+EAPI=3
+
+inherit findlib eutils multilib
+
+DESCRIPTION="Ocaml implementation of expect to help building unitary testing"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-expect/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/475/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2[ocamlopt?]
+ dev-ml/extlib
+ dev-ml/pcre-ocaml"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ounit"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ chmod +x configure
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ --htmldir "/usr/share/doc/${PF}/html" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc; then
+ emake doc || die
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.txt CHANGES.txt AUTHORS.txt || die "doc install failed"
+}