summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-10-30 22:41:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-10-30 22:41:26 +0000
commit09371e9e5fc34b18266d733ab383af125d38166c (patch)
treeb602623099f1884205b3029c4046e7a99616ec04 /dev-ml/lablgtk
parentsourceview useflag for lablgtk (diff)
downloadgentoo-2-09371e9e5fc34b18266d733ab383af125d38166c.tar.gz
gentoo-2-09371e9e5fc34b18266d733ab383af125d38166c.tar.bz2
gentoo-2-09371e9e5fc34b18266d733ab383af125d38166c.zip
version bump
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-ml/lablgtk')
-rw-r--r--dev-ml/lablgtk/ChangeLog7
-rw-r--r--dev-ml/lablgtk/files/digest-lablgtk-2.10.03
-rw-r--r--dev-ml/lablgtk/lablgtk-2.10.0.ebuild66
3 files changed, 75 insertions, 1 deletions
diff --git a/dev-ml/lablgtk/ChangeLog b/dev-ml/lablgtk/ChangeLog
index 7b0157c2201f..ce3f261379c7 100644
--- a/dev-ml/lablgtk/ChangeLog
+++ b/dev-ml/lablgtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/lablgtk
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/ChangeLog,v 1.53 2007/08/30 17:02:42 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/ChangeLog,v 1.54 2007/10/30 22:41:25 aballier Exp $
+
+*lablgtk-2.10.0 (30 Oct 2007)
+
+ 30 Oct 2007; Alexis Ballier <aballier@gentoo.org> +lablgtk-2.10.0.ebuild:
+ version bump
30 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing mattam from metadata due to his retirement (see #30021 for reference).
diff --git a/dev-ml/lablgtk/files/digest-lablgtk-2.10.0 b/dev-ml/lablgtk/files/digest-lablgtk-2.10.0
new file mode 100644
index 000000000000..149a437c9c6e
--- /dev/null
+++ b/dev-ml/lablgtk/files/digest-lablgtk-2.10.0
@@ -0,0 +1,3 @@
+MD5 711c29cb6cf7883f5391fd713ff4c225 lablgtk-2.10.0.tar.gz 742009
+RMD160 c149acc683c43b846347aeb3454966fd6ce1cce8 lablgtk-2.10.0.tar.gz 742009
+SHA256 c0565648caaeb302d32941835c69decf279121ac7e10fd52951991cf876448e5 lablgtk-2.10.0.tar.gz 742009
diff --git a/dev-ml/lablgtk/lablgtk-2.10.0.ebuild b/dev-ml/lablgtk/lablgtk-2.10.0.ebuild
new file mode 100644
index 000000000000..1ecda2bdc356
--- /dev/null
+++ b/dev-ml/lablgtk/lablgtk-2.10.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/lablgtk-2.10.0.ebuild,v 1.1 2007/10/30 22:41:25 aballier Exp $
+
+inherit eutils multilib
+
+IUSE="debug doc glade gnome gnomecanvas sourceview opengl spell svg"
+
+DESCRIPTION="Objective CAML interface for Gtk+2"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html"
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
+LICENSE="LGPL-2.1 as-is"
+
+DEPEND=">=x11-libs/gtk+-2.10
+ >=dev-lang/ocaml-3.07
+ dev-util/pkgconfig
+ svg? ( >=gnome-base/librsvg-2.2 )
+ glade? ( >=gnome-base/libglade-2.0.1 )
+ gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
+ gnome? ( >=gnome-base/gnome-panel-2.4.0
+ >=gnome-base/libgnomeui-2.4.0 )
+ opengl? ( >=dev-ml/lablgl-0.98
+ >=x11-libs/gtkglarea-1.9 )
+ spell? ( app-text/gtkspell )
+ sourceview? ( =x11-libs/gtksourceview-1* )
+ "
+
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_with svg rsvg) \
+ $(use_with glade) \
+ $(use_with gnome gnomeui) \
+ $(use_with gnome panel) \
+ $(use_with opengl gl) \
+ $(use_with spell gtkspell) \
+ $(use_with sourceview gtksourceview) \
+ $(use_with gnomecanvas) \
+ || die "configure failed"
+
+ emake -j1 all opt || die "make failed"
+}
+
+install_examples() {
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*.ml examples/*.rgb
+}
+
+src_install () {
+ emake install DESTDIR="${D}" || die
+
+ # ocamlfind support
+ dosym /usr/$(get_libdir)/ocaml/lablgtk2 /usr/$(get_libdir)/ocaml/site-packages/lablgtk2
+ insinto /usr/$(get_libdir)/ocaml/lablgtk2
+ doins META
+
+ dodoc CHANGES README CHANGES.API
+ use doc && install_examples
+}
+
+pkg_postinst () {
+ use doc && elog "To run the examples you can use the lablgtk2 toplevel."
+ use doc && elog "e.g: lablgtk2 /usr/share/doc/${P}/examples/testgtk.ml"
+}