summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-09-10 21:01:37 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-09-10 21:01:37 +0000
commitd64cbbb4f987c7c842ca21ba1e5ce58be3c97107 (patch)
treefaf3baead3739bbc40bd0b56d7dd5b1d8647b1c6 /dev-ml/facile/facile-1.1.ebuild
parentInitial import from the GNUstep overlay (diff)
downloadgentoo-2-d64cbbb4f987c7c842ca21ba1e5ce58be3c97107.tar.gz
gentoo-2-d64cbbb4f987c7c842ca21ba1e5ce58be3c97107.tar.bz2
gentoo-2-d64cbbb4f987c7c842ca21ba1e5ce58be3c97107.zip
Imported from the KDE4 overlay to the tree for KDE3 (and KDE4 later on). Thanks, Zephyrus!
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-ml/facile/facile-1.1.ebuild')
-rw-r--r--dev-ml/facile/facile-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/facile/facile-1.1.ebuild b/dev-ml/facile/facile-1.1.ebuild
new file mode 100644
index 000000000000..0c50b47917ae
--- /dev/null
+++ b/dev-ml/facile/facile-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.1 2007/09/10 21:01:37 philantrop Exp $
+
+DESCRIPTION="FaCiLe is a constraint programming library on integer and integer set finite domains written in OCaml."
+HOMEPAGE="http://www.recherche.enac.fr/log/facile/"
+SRC_URI="http://www.recherche.enac.fr/log/facile/distrib/${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.09.3-r1"
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ # This is a custom configure script and it does not support standard options
+ ./configure --faciledir ${D}$(ocamlc -where)/facile/
+ emake || die "Compilation failed"
+}
+
+src_install(){
+ dodir $(ocamlc -where)
+ emake install || die "Installation failed"
+ dodoc LICENSE README || die "installing docs failed"
+}