summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-01 14:03:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-01 14:03:05 +0000
commit439002faafd6fbe9dd561517cba4633c266068d9 (patch)
tree2ddc16d9995e9bec4a7aa54ee7b42cb585cb73e9 /dev-ml/core
parentAdd missing PYTHON_USEDEP on libpeas. (diff)
downloadgentoo-2-439002faafd6fbe9dd561517cba4633c266068d9.tar.gz
gentoo-2-439002faafd6fbe9dd561517cba4633c266068d9.tar.bz2
gentoo-2-439002faafd6fbe9dd561517cba4633c266068d9.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/core')
-rw-r--r--dev-ml/core/ChangeLog7
-rw-r--r--dev-ml/core/core-112.01.01.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index 5f2c30f8793b..b77f5e7766f6 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.30 2014/11/28 17:58:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.31 2014/12/01 14:03:05 aballier Exp $
+
+*core-112.01.01 (01 Dec 2014)
+
+ 01 Dec 2014; Alexis Ballier <aballier@gentoo.org> +core-112.01.01.ebuild:
+ version bump
28 Nov 2014; Alexis Ballier <aballier@gentoo.org> core-111.28.00.ebuild:
update deps for ocaml 4.02
diff --git a/dev-ml/core/core-112.01.01.ebuild b/dev-ml/core/core-112.01.01.ebuild
new file mode 100644
index 000000000000..e98cf4328ccb
--- /dev/null
+++ b/dev-ml/core/core-112.01.01.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-112.01.01.ebuild,v 1.1 2014/12/01 14:03:05 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit eutils oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}.00/individual/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/core_kernel-109.35.00:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/variantslib-109.15.00:=
+ >=dev-ml/comparelib-109.27.00:=
+ >=dev-ml/herelib-109.35.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ dev-ml/custom_printf:=
+ dev-ml/pa_bench:=
+ dev-ml/pa_test:=
+ dev-ml/enumerate:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+DOCS=( "README.md" )