summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-01-19 15:59:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-01-19 15:59:08 +0000
commit1d1f9a2de7120f58d975f426da0e98c96a55a8d3 (patch)
tree7b419da0fcda246f50688ad98b8106c513b37433 /dev-ml/core
parentversion bump (diff)
downloadgentoo-2-1d1f9a2de7120f58d975f426da0e98c96a55a8d3.tar.gz
gentoo-2-1d1f9a2de7120f58d975f426da0e98c96a55a8d3.tar.bz2
gentoo-2-1d1f9a2de7120f58d975f426da0e98c96a55a8d3.zip
version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/core')
-rw-r--r--dev-ml/core/ChangeLog9
-rw-r--r--dev-ml/core/core-109.60.00.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index 9d1562755498..ff8e946a71d4 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/core
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.25 2013/08/19 15:28:17 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.26 2014/01/19 15:59:08 aballier Exp $
+
+*core-109.60.00 (19 Jan 2014)
+
+ 19 Jan 2014; Alexis Ballier <aballier@gentoo.org> +core-109.60.00.ebuild:
+ version bump
*core-109.38.00 (19 Aug 2013)
diff --git a/dev-ml/core/core-109.60.00.ebuild b/dev-ml/core/core-109.60.00.ebuild
new file mode 100644
index 000000000000..e777d228f3fa
--- /dev/null
+++ b/dev-ml/core/core-109.60.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-109.60.00.ebuild,v 1.1 2014/01/19 15:59:08 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit eutils oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/core_kernel-109.35.00:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/variantslib-109.15.00:=
+ >=dev-ml/comparelib-109.27.00:=
+ >=dev-ml/herelib-109.35.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ dev-ml/pa_bench:=
+ dev-ml/pa_test:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+DOCS=( "README.md" )
+
+#src_prepare() {
+# has_version '>=dev-lang/ocaml-4.01.0_beta' && epatch "${FILESDIR}/${PN}-ocaml-4.01.patch"
+#}