summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-18 12:01:52 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-18 12:01:52 +0000
commitb34511293b23346b2b38d23b3daeff49f0a9de6a (patch)
treebe662f66db64321f67c7c0f7a6332cca8d3aacea /dev-ml/camlzip
parentVersion bump, fixes bug #59861 (Manifest recommit) (diff)
downloadgentoo-2-b34511293b23346b2b38d23b3daeff49f0a9de6a.tar.gz
gentoo-2-b34511293b23346b2b38d23b3daeff49f0a9de6a.tar.bz2
gentoo-2-b34511293b23346b2b38d23b3daeff49f0a9de6a.zip
Import of camlzip, bug #50621
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/ChangeLog11
-rw-r--r--dev-ml/camlzip/Manifest5
-rw-r--r--dev-ml/camlzip/camlzip-1.01.ebuild69
-rw-r--r--dev-ml/camlzip/files/META5
-rw-r--r--dev-ml/camlzip/files/digest-camlzip-1.011
-rw-r--r--dev-ml/camlzip/metadata.xml5
6 files changed, 96 insertions, 0 deletions
diff --git a/dev-ml/camlzip/ChangeLog b/dev-ml/camlzip/ChangeLog
new file mode 100644
index 000000000000..644f905da063
--- /dev/null
+++ b/dev-ml/camlzip/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/camlzip
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.1 2004/08/18 12:01:52 mattam Exp $
+
+*camlzip-1.01 (18 Aug 2004)
+
+ 18 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> camlzip-1.01.ebuild,
+ metadata.xml, files/META:
+ Add camlzip, an ocaml library to access compressed files (g?zip, jar), thanks
+ to Julien TIERNY <julien.tierny@wanadoo.fr> for the ebuild (bug #50621)
+
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
new file mode 100644
index 000000000000..b34e6e39c893
--- /dev/null
+++ b/dev-ml/camlzip/Manifest
@@ -0,0 +1,5 @@
+MD5 95aca67a6eff656758ed011c4d307144 camlzip-1.01.ebuild 1999
+MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
+MD5 6081ec5dbb7302216940749b0f1cb7d9 ChangeLog 399
+MD5 144d02af76045780262191bff2b44b62 files/META 104
+MD5 247ab601d786744715f10b4952872f98 files/digest-camlzip-1.01 63
diff --git a/dev-ml/camlzip/camlzip-1.01.ebuild b/dev-ml/camlzip/camlzip-1.01.ebuild
new file mode 100644
index 000000000000..1cfc59749513
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.01.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.01.ebuild,v 1.1 2004/08/18 12:01:52 mattam Exp $
+
+IUSE=""
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://cristal.inria.fr/~xleroy/software.html#camlzip"
+SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${PN}-${PV}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-lang/ocaml-3.04 \
+ >=sys-libs/zlib-1.1.3 \
+ sys-apps/sed \
+ >=dev-ml/findlib-0.8"
+RDEPEND=">=dev-ml/findlib-0.8"
+
+src_unpack() {
+ local CAT=$(which cat)
+ local CP=$(which cp)
+ local MV=$(which mv)
+ local SED=$(which sed)
+
+ unpack ${A}
+ $CP /usr/lib/ocaml/ld.conf ${WORKDIR}
+ # The ML linker configuration file is copied
+ # into the ${WORKDIR} so as to compile properly
+ # the ML related code.
+ #
+ # NB: Note that this file should NOT be copied
+ # to the ${D}usr/lib/ocaml/ directory otherwise
+ # it would be deleted at camlzip's unmerge,
+ # which would break OCAML environment.
+ # Julien TIERNY <julien.tierny@wanadoo.fr>
+ $CAT ${S}/Makefile | \
+ $SED "s/\`\$(OCAMLC) -where\`/\${D}\`ocamlfind\ printconf\ path\`/" | \
+ $SED "s/ldconf=\${D}usr\/lib\/ocaml\/ld.conf;/ldconf=\${WORKDIR}\/ld.conf/" > \
+ ${S}/Makefile.tmp
+ $MV ${S}/Makefile.tmp ${S}/Makefile
+}
+
+src_compile() {
+ emake all || die "Failed at compilation step !!!"
+ emake allopt || die "Failed at ML compilation step !!!"
+}
+
+src_install() {
+ einstall || die "Failed at installation step !!!"
+ emake installopt || die "Failed at ML related installation step !!!"
+ dodoc README
+ insopts -m 644
+ insinto `ocamlfind printconf path`/zip
+ doins ${FILESDIR}/META
+}
+
+pkg_postinst() {
+ local ECHO=$(which echo)
+ local CAT=$(which cat)
+ local GREP=$(which grep)
+
+ if [ -z `$CAT /usr/lib/ocaml/ld.conf | $GREP zip` ]
+ then
+ einfo "Patching OCAML linker configuration file..."
+ $ECHO "`ocamlfind printconf path`zip" >> /usr/lib/ocaml/ld.conf
+ fi
+}
diff --git a/dev-ml/camlzip/files/META b/dev-ml/camlzip/files/META
new file mode 100644
index 000000000000..c852fa144a55
--- /dev/null
+++ b/dev-ml/camlzip/files/META
@@ -0,0 +1,5 @@
+version="1.01"
+requires="unix"
+linkopts="-cclib -lz"
+archive(byte)="zip.cma"
+archive(native)="zip.cmxa"
diff --git a/dev-ml/camlzip/files/digest-camlzip-1.01 b/dev-ml/camlzip/files/digest-camlzip-1.01
new file mode 100644
index 000000000000..0d0e36c33ebe
--- /dev/null
+++ b/dev-ml/camlzip/files/digest-camlzip-1.01
@@ -0,0 +1 @@
+MD5 728940dc0958493274314d576c16ef68 camlzip-1.01.tar.gz 15113
diff --git a/dev-ml/camlzip/metadata.xml b/dev-ml/camlzip/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/camlzip/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>