summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-20 19:39:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-20 19:39:06 +0000
commit844d236175a3e5fab479e9f9bf66c9fe5ebaff83 (patch)
treeff0eac584f531b5bda452830b1be61b415252a23 /dev-ml/camlp5
parentRemove old versions (diff)
downloadgentoo-2-844d236175a3e5fab479e9f9bf66c9fe5ebaff83.tar.gz
gentoo-2-844d236175a3e5fab479e9f9bf66c9fe5ebaff83.tar.bz2
gentoo-2-844d236175a3e5fab479e9f9bf66c9fe5ebaff83.zip
Import a patch from upstream/debian to fix latest coq build failure, bug #352174 by Thomas Kahle <tomka@gentoo.org> and Olivier Huber
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/ChangeLog12
-rw-r--r--dev-ml/camlp5/camlp5-6.02.1-r1.ebuild50
-rw-r--r--dev-ml/camlp5/files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.patch23
3 files changed, 83 insertions, 2 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 3beded3e8275..253a741ae27b 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ml/camlp5
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.52 2010/12/24 16:04:41 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.53 2011/01/20 19:39:06 aballier Exp $
+
+*camlp5-6.02.1-r1 (20 Jan 2011)
+
+ 20 Jan 2011; Alexis Ballier <aballier@gentoo.org> +camlp5-6.02.1-r1.ebuild,
+ +files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.pat
+ ch:
+ Import a patch from upstream/debian to fix latest coq build failure, bug
+ #352174 by Thomas Kahle <tomka@gentoo.org> and Olivier Huber
24 Dec 2010; Alexis Ballier <aballier@gentoo.org> -camlp5-5.15.ebuild,
-camlp5-6.02.0.ebuild:
diff --git a/dev-ml/camlp5/camlp5-6.02.1-r1.ebuild b/dev-ml/camlp5/camlp5-6.02.1-r1.ebuild
new file mode 100644
index 000000000000..c5270748163a
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-6.02.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.02.1-r1.ebuild,v 1.1 2011/01/20 19:39:06 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib eutils
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Fix-regression-in-pretty-printing-of-labelled-argume.patch"
+}
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake || die "emake failed"
+ if use ocamlopt; then
+ emake opt || die "Compiling native code programs failed"
+ emake opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}
diff --git a/dev-ml/camlp5/files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.patch b/dev-ml/camlp5/files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.patch
new file mode 100644
index 000000000000..56a554d5374c
--- /dev/null
+++ b/dev-ml/camlp5/files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.patch
@@ -0,0 +1,23 @@
+From: Stephane Glondu <steph@glondu.net>
+Date: Mon, 6 Dec 2010 11:39:34 +0100
+Subject: [PATCH] Fix regression in pretty-printing of labelled arguments
+
+Patch provided by Daniel de Rauglaudre, applied in upstream CVS.
+---
+ etc/pr_o.ml | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/etc/pr_o.ml b/etc/pr_o.ml
+index ad8d6b9..747e64e 100644
+--- a/etc/pr_o.ml
++++ b/etc/pr_o.ml
+@@ -2080,7 +2080,7 @@ value poly_type pc =
+ value label_ipatt expr pc (p, oe) =
+ match Pcaml.unvala oe with
+ [ Some e -> pprintf pc "~%p:%p" patt p expr e
+- | None -> patt pc p ]
++ | None -> pprintf pc "~%p" patt p ]
+ ;
+
+ EXTEND_PRINTER
+--