summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-08 08:12:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-08 08:12:21 +0000
commitb6c111be0233d1f81a3f6735035a69721d816aa6 (patch)
treef42dc1939e2beeb7ae35a4dbafbda97ce191b7f1 /dev-lisp
parent(Portage version: 2.0.51-r15) (Manifest recommit) (diff)
downloadgentoo-2-b6c111be0233d1f81a3f6735035a69721d816aa6.tar.gz
gentoo-2-b6c111be0233d1f81a3f6735035a69721d816aa6.tar.bz2
gentoo-2-b6c111be0233d1f81a3f6735035a69721d816aa6.zip
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-unit/ChangeLog10
-rw-r--r--dev-lisp/cl-unit/cl-unit-1.3.1-r1.ebuild7
-rw-r--r--dev-lisp/cl-unit/cl-unit-1.3.1.ebuild43
-rw-r--r--dev-lisp/cl-unit/cl-unit-1.3.ebuild25
-rw-r--r--dev-lisp/cl-unit/files/1.3.1-no-self-tests-gentoo.patch102
-rw-r--r--dev-lisp/cl-unit/files/digest-cl-unit-1.31
-rw-r--r--dev-lisp/cl-unit/files/digest-cl-unit-1.3.12
7 files changed, 114 insertions, 76 deletions
diff --git a/dev-lisp/cl-unit/ChangeLog b/dev-lisp/cl-unit/ChangeLog
index b035cd2aaefc..1120800be1cf 100644
--- a/dev-lisp/cl-unit/ChangeLog
+++ b/dev-lisp/cl-unit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/cl-unit
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-unit/ChangeLog,v 1.5 2004/06/24 23:56:36 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-unit/ChangeLog,v 1.6 2005/02/08 08:12:21 mkennedy Exp $
+
+ 08 Feb 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/1.3.1-no-self-tests-gentoo.patch, cl-unit-1.3.1-r1.ebuild,
+ -cl-unit-1.3.1.ebuild, -cl-unit-1.3.ebuild:
+ Remove self tests which would otherwise install into COMMON-LISP-USER
+ automatically; Remove old ebuilds.
*cl-unit-1.3.1-r1 (12 Feb 2004)
diff --git a/dev-lisp/cl-unit/cl-unit-1.3.1-r1.ebuild b/dev-lisp/cl-unit/cl-unit-1.3.1-r1.ebuild
index 3fe0b430d636..919193cd25bb 100644
--- a/dev-lisp/cl-unit/cl-unit-1.3.1-r1.ebuild
+++ b/dev-lisp/cl-unit/cl-unit-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-unit/cl-unit-1.3.1-r1.ebuild,v 1.3 2004/06/24 23:56:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-unit/cl-unit-1.3.1-r1.ebuild,v 1.4 2005/02/08 08:12:21 mkennedy Exp $
inherit common-lisp eutils
@@ -23,7 +23,8 @@ CLPACKAGE=clunit
src_unpack() {
unpack ${A}
- epatch cl-unit_${PV}-${DEB_PV}.diff
+ epatch cl-unit_${PV}-${DEB_PV}.diff || die
+ epatch ${FILESDIR}/${PV}-no-self-tests-gentoo.patch || die
}
src_install() {
diff --git a/dev-lisp/cl-unit/cl-unit-1.3.1.ebuild b/dev-lisp/cl-unit/cl-unit-1.3.1.ebuild
deleted file mode 100644
index b4ddac46edbf..000000000000
--- a/dev-lisp/cl-unit/cl-unit-1.3.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-unit/cl-unit-1.3.1.ebuild,v 1.4 2004/06/24 23:56:36 agriffis Exp $
-
-inherit common-lisp eutils
-
-DEB_PV=1
-
-DESCRIPTION="A regression suite library for Common Lisp"
-HOMEPAGE="http://www.ancar.org/CLUnit/docs/CLUnit.html http://packages.debian.org/unstable/devel/cl-unit.html"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-unit/${PN}_${PV}.orig.tar.gz
- http://ftp.debian.org/debian/pool/main/c/cl-unit/cl-unit_${PV}-${DEB_PV}.diff.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=clunit
-
-src_unpack() {
- unpack ${A}
- epatch cl-unit_${PV}-${DEB_PV}.diff
-}
-
-src_install() {
- common-lisp-install *.lisp ${FILESDIR}/clunit.asd
- common-lisp-system-symlink
- dodoc license readme
- dohtml docs/*
- do-debian-credits
-}
-
-pkg_preinst() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
-}
-
-pkg_postrm() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
-}
diff --git a/dev-lisp/cl-unit/cl-unit-1.3.ebuild b/dev-lisp/cl-unit/cl-unit-1.3.ebuild
deleted file mode 100644
index 278f29cdf7ec..000000000000
--- a/dev-lisp/cl-unit/cl-unit-1.3.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-unit/cl-unit-1.3.ebuild,v 1.4 2004/07/14 16:18:20 agriffis Exp $
-
-inherit common-lisp
-
-DESCRIPTION="A regression suite library for Common Lisp"
-HOMEPAGE="http://www.ancar.org/CLUnit/docs/CLUnit.html
- http://packages.debian.org/unstable/devel/cl-unit.html"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-unit/${PN}_${PV}.orig.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=clunit
-
-src_install() {
- common-lisp-install *.lisp ${FILESDIR}/clunit.asd
- common-lisp-system-symlink
- dodoc license readme
- dohtml docs/*
-}
diff --git a/dev-lisp/cl-unit/files/1.3.1-no-self-tests-gentoo.patch b/dev-lisp/cl-unit/files/1.3.1-no-self-tests-gentoo.patch
new file mode 100644
index 000000000000..4cf3b40d192c
--- /dev/null
+++ b/dev-lisp/cl-unit/files/1.3.1-no-self-tests-gentoo.patch
@@ -0,0 +1,102 @@
+diff -ur cl-unit-1.3.1.orig/clunit.lisp cl-unit-1.3.1/clunit.lisp
+--- cl-unit-1.3.1.orig/clunit.lisp 2003-09-07 01:35:26.000000000 -0500
++++ cl-unit-1.3.1/clunit.lisp 2005-02-08 02:01:10.456719586 -0600
+@@ -287,97 +287,3 @@
+ failed-tests
+ ;with-supressed-summary
+ ))
+-
+-(in-package "COMMON-LISP-USER")
+-(use-package :org.ancar.CLUnit)
+-
+-;;;
+-;;; Self test...
+-;;;
+-
+-;; tests basic test definition
+-(load-time-value (progn
+-
+-(deftest "test1" :category "CLUnit-pass1"
+- :test-fn #'(lambda () (eq (car '(a)) 'a)))
+-
+-;; tests input-fn
+-(deftest "test-2" :category "CLUnit-pass1"
+- :input-fn #'(lambda () '(a))
+- :test-fn #'(lambda (x) (eq (car x) 'a)))
+-
+-;; tests output-fn
+-(deftest "test-3" :category "CLUnit-pass1"
+- :input-fn #'(lambda () '(a))
+- :output-fn #'(lambda () 'a)
+- :test-fn #'(lambda (x) (car x)))
+-
+-;; tests remove-test, run-category, and multiple-values in test-fn and
+-;; output-fn
+-(deftest "meta" :category "CLUnit-meta"
+- :input-fn #'(lambda () (remove-test "test1"))
+- :test-fn #'(lambda (x) (declare (ignore x)) (run-category "CLUnit-pass1"))
+- :output-fn #'(lambda () (values t 0 2)))
+-
+-;; tests multiple values from input-fn to test-fn
+-(deftest "test1" :category "CLUnit-pass2"
+- :input-fn #'(lambda () (values 'a '(b)))
+- :test-fn #'cons
+- :output-fn #'(lambda () '(a b)))
+-
+-;;check error trapping
+-(deftest "meta2" :category "CLUnit-meta"
+- :input-fn
+- #'(lambda () (deftest "Error test" :category "CLUnit-pass3"
+- :test-fn #'(lambda ()
+- (remove-test "Error test") (error "Dummy error"))))
+- :test-fn #'(lambda (x) (declare (ignore x)) (run-category "CLUnit-pass3"))
+- :output-fn #'(lambda () (values nil 1 0)))
+-
+-;;check input-form
+-(deftest "testx" :category "CLUnit"
+- :input-form '(a b c)
+- :test-fn #'car
+- :output-fn #'(lambda () 'a))
+-
+-;;check output form
+-(deftest "testx2" :category "CLUnit"
+- :input-form '(a b c)
+- :test-fn #'car
+- :output-form 'a)
+-
+-;;check multiple input-forms
+-(deftest "testx3" :category "CLUnit"
+- :input-form (values '(1 2 3) '(10 20 30))
+- :test-fn #'(lambda (&rest lists) (car lists))
+- :output-fn #'(lambda () '(1 2 3)))
+-
+-;;check multiple output-forms
+-(deftest "testx4" :category "CLUnit"
+- :input-form (values '(1 2 3) '(10 20 30))
+- :test-fn #'(lambda (&rest lists) (apply #'values lists))
+- :output-fn #'(lambda () (values '(1 2 3) '(10 20 30))))
+-
+-;;check failed-tests
+-(deftest "meta5" :category "CLUnit-meta"
+- :input-fn
+- #'(lambda () (deftest "Error test" :category "CLUnit-pass4"
+- :test-fn #'(lambda ()
+- (remove-test "Error test") (error "Dummy error"))))
+- :test-fn #'(lambda (x) (declare (ignore x))
+- (run-category "CLUnit-pass4")
+- (values (length (failed-tests)) (org.ancar.CLUnit::descr (car (failed-tests)))))
+- :output-fn #'(lambda () (values 1 "Error test")))
+-
+-(deftest "Test compare-fn"
+- :test-fn #'(lambda () "abc")
+- :output-form "abc"
+- :compare-fn #'(lambda (rlist1 rlist2)
+- (not (null (reduce #'(lambda (x y) (and x y))
+- (mapcar #'string-equal rlist1 rlist2) :initial-value t)))))
+-
+-;;; run self test
+-(when (run-all-tests)
+- (format t "~&CLUnit self-test passed.~%")
+- (clear-tests)
+- (values))))
+Only in cl-unit-1.3.1: clunit.lisp~
diff --git a/dev-lisp/cl-unit/files/digest-cl-unit-1.3 b/dev-lisp/cl-unit/files/digest-cl-unit-1.3
deleted file mode 100644
index b15e68b31ecd..000000000000
--- a/dev-lisp/cl-unit/files/digest-cl-unit-1.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e4d84cf603ed3106fb50353b683bc6af cl-unit_1.3.orig.tar.gz 36889
diff --git a/dev-lisp/cl-unit/files/digest-cl-unit-1.3.1 b/dev-lisp/cl-unit/files/digest-cl-unit-1.3.1
deleted file mode 100644
index a278397ce5fe..000000000000
--- a/dev-lisp/cl-unit/files/digest-cl-unit-1.3.1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 caf1c8c9ef2e6cfa6d40b3189f883566 cl-unit_1.3.1.orig.tar.gz 36105
-MD5 e1c7a3f253bb011bfae83b1f293f6f03 cl-unit_1.3.1-1.diff.gz 2671