summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-04-11 06:28:25 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-04-11 06:28:25 +0000
commit51dad1af5852a03c8d5988532bd59ad81086423a (patch)
treecef57e55f9fb80f0e0bb365d5fb178744f84147b /dev-lisp
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-51dad1af5852a03c8d5988532bd59ad81086423a.tar.gz
gentoo-2-51dad1af5852a03c8d5988532bd59ad81086423a.tar.bz2
gentoo-2-51dad1af5852a03c8d5988532bd59ad81086423a.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog7
-rw-r--r--dev-lisp/clisp/clisp-2.33-r1.ebuild136
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.33-r11
3 files changed, 143 insertions, 1 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index f8b7bef42760..0eb0e3b5a9a1 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.17 2004/03/30 20:58:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.18 2004/04/11 06:28:25 mkennedy Exp $
+
+*clisp-2.33-r1 (11 Apr 2004)
+
+ 11 Apr 2004; <mkennedy@gentoo.org> clisp-2.33-r1.ebuild:
+ Don't use -march=athlon-xp
30 Mar 2004; Donnie Berkholz <spyderous@gentoo.org>; clisp-2.28.ebuild,
clisp-2.29.ebuild, clisp-2.30-r1.ebuild, clisp-2.30.ebuild,
diff --git a/dev-lisp/clisp/clisp-2.33-r1.ebuild b/dev-lisp/clisp/clisp-2.33-r1.ebuild
new file mode 100644
index 000000000000..057b036fd2e9
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.33-r1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33-r1.ebuild,v 1.1 2004/04/11 06:28:25 mkennedy Exp $
+
+inherit flag-o-matic common-lisp-common
+
+IUSE="X fastcgi postgres nls berkdb pcre"
+
+# Handle the case where the user has some other -falign-functions
+# option set. Bug 34630.
+
+if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+-falign-functions=4}
+fi
+
+# Fails to compile without -falign-functions=4 when -march=pentium4
+# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+
+if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+fi
+
+# Athlon XP users report problems with -O3 optimization. In this
+# block, we remove any optimization flag. Depending on bug 34497. we
+# may be able to reduce optimization to -O2.
+
+if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+fi
+
+# The previous stanza might not be necessary. Bug 39830.
+
+if is-flag '-march=athlon-xp'; then
+ replace-flags '-march=athlon-xp' '-mcpu=athlon-xp'
+fi
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+DEPEND="dev-libs/libsigsegv
+ dev-lisp/common-lisp-controller
+ fastcgi? ( dev-libs/fcgi )
+ postgres? ( dev-db/postgresql )
+ X? ( virtual/x11 )
+ readline? ( sys-libs/readline )
+ nls? ( sys-devel/gettext )
+ berkdb? ( =sys-libs/db-4* )
+ pcre? ( dev-libs/libpcre )"
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}/fastcgi-Makefile.in-gentoo.patch
+ epatch ${FILESDIR}/${PV}/berkely-db-configure-gentoo.patch.gz
+}
+
+src_compile() {
+ einfo "Using CFLAGS: ${CFLAGS}"
+ export CC="${CC} ${CFLAGS}"
+ unset CFLAGS CXXFLAGS
+ local myconf="--with-dynamic-ffi
+ --with-unicode
+ --with-module=regexp
+ --with-module=syscalls
+ --with-module=wildcard
+ --with-module=bindings/glibc"
+ use readline || myconf="${myconf} --with-noreadline"
+ use nls || myconf="${myconf} --with-nogettext"
+ use X && myconf="${myconf} --with-module=clx/new-clx"
+ if use postgres; then
+ myconf="${myconf} --with-module=postgresql"
+ CC="${CC} -I $(pg_config --includedir)"
+ fi
+ use fastcgi && myconf="${myconf} --with-module=fastcgi"
+ use berkdb && myconf="${myconf} --with-module=berkeley-db"
+ use pcre && myconf="${myconf} --with-module=pcre"
+ ./configure --prefix=/usr ${myconf} build || die "./configure failed"
+ cd build
+ ./makemake ${myconf} >Makefile
+ make config.lisp
+ sed -i 's,"vi","nano",g' config.lisp
+ sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
+ make || die
+}
+
+src_install() {
+ cd build && make DESTDIR=${D} prefix=/usr install-bin || die
+ doman clisp.1
+ dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
+ ANNOUNCE clisp.dvi clisp.html
+
+ rm -f ${D}/usr/lib/clisp/base/*
+ (cd ${D}/usr/lib/clisp/base && ln -s ../full/* .)
+ chmod a+x ${D}/usr/lib/clisp/clisp-link
+
+ # install common-lisp-controller profile
+ exeinto /usr/lib/common-lisp/bin
+ doexe ${FILESDIR}/clisp.sh
+ insinto /usr/lib/clisp
+ doins ${FILESDIR}/install-clc.lisp
+
+ keepdir /usr/lib/common-lisp/clisp
+}
+
+pkg_preinst() {
+ local clisp_dir=/usr/lib/clisp
+ local old_mem=$clisp_dir/full/lispinit.mem
+ local new_mem=$clisp_dir/full/lispinit-new.mem
+ local clean_mem=$clisp_dir/full/lispinit-clean.mem
+ local lisp_run=$clisp_dir/full/lisp.run
+ rm -f $old_mem $new_mem $clean_mem $lisp_run
+}
+
+pkg_postinst() {
+ standard-impl-postinst clisp
+ while read line; do einfo "${line}"; done <<EOF
+
+PLEASE NOTE: FASL files (.fas) created by previous versions of CLISP
+are not compatible with this version of CLISP (${PV}). You will need
+to re-create your FASLs via. recompilation. FASLs in
+/usr/lib/common-lisp/clisp for Common Lisp Controller-installed Lisp
+packages have aready been recompiled for you.
+
+EOF
+}
+
+pkg_postrm() {
+ standard-impl-postrm clisp /usr/bin/clisp
+}
diff --git a/dev-lisp/clisp/files/digest-clisp-2.33-r1 b/dev-lisp/clisp/files/digest-clisp-2.33-r1
new file mode 100644
index 000000000000..4bdfa802ec07
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.33-r1
@@ -0,0 +1 @@
+MD5 8724eccb8933eedec31a06206c79e74d clisp-2.33.tar.bz2 6072837