summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-17 21:47:26 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-17 21:47:26 +0000
commit8faf0abecc89d75cc8fca443f1116ca917b3220b (patch)
tree62cd79f1a9b98a92468d5160130e94777fe9a1a8 /dev-lisp/mzscheme
parentAdded ebuild for geotrace (diff)
downloadgentoo-2-8faf0abecc89d75cc8fca443f1116ca917b3220b.tar.gz
gentoo-2-8faf0abecc89d75cc8fca443f1116ca917b3220b.tar.bz2
gentoo-2-8faf0abecc89d75cc8fca443f1116ca917b3220b.zip
MzScheme 103_pre1
Diffstat (limited to 'dev-lisp/mzscheme')
-rw-r--r--dev-lisp/mzscheme/ChangeLog24
-rw-r--r--dev-lisp/mzscheme/files/digest-mzscheme-103_pre11
-rw-r--r--dev-lisp/mzscheme/mzscheme-103_pre1.ebuild49
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-lisp/mzscheme/ChangeLog b/dev-lisp/mzscheme/ChangeLog
new file mode 100644
index 000000000000..8dcf058ccec0
--- /dev/null
+++ b/dev-lisp/mzscheme/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for dev-lisp/mzscheme
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/mzscheme/ChangeLog,v 1.1 2002/02/17 21:47:26 karltk Exp $
+
+*mzscheme-103_pre1 ( 17 Feb 2002 )
+
+ 17 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> ChangeLog files/digest-mzscheme-103_pre1 mzscheme-103_pre1:
+
+ MzScheme is an implementation of the Scheme programming language for
+ Windows 95/98/NT/2000, MacOS, Unix, and BeOS. MzScheme is R4RS-compliant
+ (including the full numerical tower) and nearly R5RS-compliant (some macro
+ support is lacking). MzScheme also provides:
+
+ * Pre-emptive threads for all platforms
+ * Generative structures (a.k.a. record datatypes)
+ * Built-in exceptions; each primitive error raises a specific exception
+ * First-class compilation units (modules) for organizing program components
+ * A class-based object system reminiscent of C++/Java
+ * Built-in regular expression matching tools
+ * Simple TCP communication support on all platforms
+ * Portable filesystem access procedures
+ * Platform-specific process control, including AppleEvent support
+
+ This ebuild does not pre-compile the standard-library, which is untested.
diff --git a/dev-lisp/mzscheme/files/digest-mzscheme-103_pre1 b/dev-lisp/mzscheme/files/digest-mzscheme-103_pre1
new file mode 100644
index 000000000000..65a7ce62459c
--- /dev/null
+++ b/dev-lisp/mzscheme/files/digest-mzscheme-103_pre1
@@ -0,0 +1 @@
+MD5 47fb0a8270fc06dbb9541aa087051503 mzscheme.src.unix.tar.gz 1608987
diff --git a/dev-lisp/mzscheme/mzscheme-103_pre1.ebuild b/dev-lisp/mzscheme/mzscheme-103_pre1.ebuild
new file mode 100644
index 000000000000..cec0cd250d93
--- /dev/null
+++ b/dev-lisp/mzscheme/mzscheme-103_pre1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/mzscheme/mzscheme-103_pre1.ebuild,v 1.1 2002/02/17 21:47:26 karltk Exp $
+
+S=${WORKDIR}/plt
+DESCRIPTION="MzScheme scheme compiler"
+SRC_URI="http://www.cs.rice.edu/CS/PLT/packages/download/103p1/mzscheme/mzscheme.src.unix.tar.gz"
+HOMEPAGE="http://www.cs.rice.edu/CS/PLT/packages/mzscheme/"
+
+DEPEND=""
+#RDEPEND=""
+
+src_compile() {
+ cd src
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ cd src
+ make DESTDIR=${D} install || die
+
+ cd ${S}
+ dodir /usr/share/mzscheme
+ dobin bin/*
+ cp -dpR collects/* ${D}/usr/share/mzscheme
+
+ doman man/man1/*
+
+ dodoc notes/COPYING.LIB
+ dodoc README
+
+ exeinto /usr/bin
+ newexe src/mzscheme/mzscheme mzscheme-bin
+
+ echo "#! /bin/sh" > ${D}/usr/bin/mzc
+ echo '/usr/bin/mzscheme-bin -mqvL start.ss compiler -- ${1+"$@"}' >> ${D}/usr/bin/mzc
+
+ echo "#! /bin/sh" > ${D}/usr/bin/mzscheme
+ echo '/usr/bin/mzscheme-bin ${1+"$@"}' >> ${D}/usr/bin/mzscheme
+
+ rm ${D}/usr/bin/{archsys,setup-plt}
+}