summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-07-29 11:29:44 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-07-29 11:29:44 +0000
commit97ceaaf4e4749221946c216a6e91e27b064e125c (patch)
tree5a81d4a61ac4dfb590443892468688268775ad72 /dev-lisp/clisp
parentMask xnc for removal. (diff)
downloadgentoo-2-97ceaaf4e4749221946c216a6e91e27b064e125c.tar.gz
gentoo-2-97ceaaf4e4749221946c216a6e91e27b064e125c.tar.bz2
gentoo-2-97ceaaf4e4749221946c216a6e91e27b064e125c.zip
bump, should fix bug 257348 and bug 267784
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog9
-rw-r--r--dev-lisp/clisp/clisp-2.48.ebuild137
2 files changed, 144 insertions, 2 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index f282c0d76f74..504d68875a64 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/clisp
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.92 2009/01/17 14:09:18 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.93 2009/07/29 11:29:44 hkbst Exp $
+
+*clisp-2.48 (29 Jul 2009)
+
+ 29 Jul 2009; Marijn Schouten <hkBst@gentoo.org> +clisp-2.48.ebuild:
+ bump, should fix bug 257348 and bug 267784
17 Jan 2009; nixnut <nixnut@gentoo.org> clisp-2.47-r1.ebuild:
ppc stable #246074
diff --git a/dev-lisp/clisp/clisp-2.48.ebuild b/dev-lisp/clisp/clisp-2.48.ebuild
new file mode 100644
index 000000000000..8ca93570c710
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.48.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.48.ebuild,v 1.1 2009/07/29 11:29:44 hkbst Exp $
+
+EAPI=2
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc -sparc ~x86"
+IUSE="hyperspec X new-clx dbus fastcgi gdbm gtk pari pcre postgres readline svm zlib"
+
+RDEPEND="virtual/libiconv
+ >=dev-libs/libsigsegv-2.4
+ >=dev-libs/ffcall-1.10
+ dbus? ( sys-apps/dbus )
+ fastcgi? ( dev-libs/fcgi )
+ gdbm? ( sys-libs/gdbm )
+ gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
+ pari? ( >=sci-mathematics/pari-2.3.0 )
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ readline? ( >=sys-libs/readline-5.0 )
+ pcre? ( dev-libs/libpcre )
+ svm? ( sci-libs/libsvm )
+ zlib? ( sys-libs/zlib )
+ X? ( new-clx? ( x11-libs/libXpm ) )
+ hyperspec? ( dev-lisp/hyperspec )"
+# berkdb? ( sys-libs/db:4.5 )
+
+DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
+
+PDEPEND="dev-lisp/gentoo-init"
+
+PROVIDE="virtual/commonlisp"
+
+enable_modules() {
+ [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
+ for m in "$@" ; do
+ einfo "enabling module $m"
+ myconf="${myconf} --with-module=${m}"
+ done
+}
+
+BUILDDIR="builddir"
+
+# modules not enabled:
+# * berkdb: must figure out a way to make the configure script pick up the
+# currect version of the library and headers
+# * dirkey: fails to compile, requiring windows.h, possibly wrong #ifdefs
+# * matlab, netica: not in portage
+# * oracle: can't install oracle-instantclient
+
+src_prepare() {
+ # More than -O1 breaks alpha/ia64
+ use alpha || use ia64 && sed -i -e 's/-O2//g' src/makemake.in
+}
+
+src_configure() {
+ # built-in features
+ local myconf="--with-ffcall --with-dynamic-modules"
+ use readline || myconf="${myconf} --with-noreadline"
+
+ # We need this to build on alpha/ia64
+ if use alpha || use ia64; then
+ replace-flags -O? -O1
+ append-flags '-D NO_MULTIMAP_SHM -D NO_MULTIMAP_FILE -D NO_SINGLEMAP -D NO_TRIVIALMAP'
+ fi
+ # default modules
+ enable_modules wildcard rawsock
+ # optional modules
+ use elibc_glibc && enable_modules bindings/glibc
+ if use X; then
+ if use new-clx; then
+ enable_modules clx/new-clx
+ else
+ enable_modules clx/mit-clx
+ fi
+ fi
+ if use postgres; then
+ enable_modules postgresql
+ CPPFLAGS="-I $(pg_config --includedir)"
+ fi
+# if use berkdb; then
+# enable_modules berkley-db
+# CPPFLAGS="${CPPFLAGS} -I /usr/include/db4.5"
+# fi
+ use dbus && enable_modules dbus
+ use fastcgi && enable_modules fastcgi
+ use gdbm && enable_modules gdbm
+ use gtk && enable_modules gtk2
+ use pari && enable_modules pari
+ use pcre && enable_modules pcre
+ use svm && enable_modules libsvm
+ use zlib && enable_modules zlib
+
+ if use hyperspec; then
+ CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
+ else
+ CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
+ fi
+
+ # configure chokes on --sysconfdir option
+ local configure="./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+ ${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR}"
+ einfo "${configure}"
+ ${configure} || die "./configure failed"
+
+ sed -i 's,"vi","nano",g' "${BUILDDIR}"/config.lisp
+
+ IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
+ sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" "${BUILDDIR}"/config.lisp
+}
+
+src_compile() {
+ cd "${BUILDDIR}"
+ # parallel build fails
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ pushd "${BUILDDIR}"
+ make DESTDIR="${D}" prefix=/usr install-bin || die
+ doman clisp.1
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
+ chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link
+ # stripping them removes common symbols (defined but uninitialised variables)
+ # which are then needed to build modules...
+ export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
+ popd
+ dohtml doc/impnotes.{css,html} doc/regexp.html doc/clisp.png
+ dodoc doc/{CLOS-guide,LISP-tutorial}.txt
+}