summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
commitf0499138e7aa5e43bdb88278d6bef3650c46e229 (patch)
treeb29a74bee14985fc7da4a51785f23c0829b3b5d5 /dev-lisp/cl-inflate
parentinitial common lisp import (diff)
downloadgentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.gz
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.bz2
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.zip
initial common lisp import
Diffstat (limited to 'dev-lisp/cl-inflate')
-rw-r--r--dev-lisp/cl-inflate/ChangeLog8
-rw-r--r--dev-lisp/cl-inflate/Manifest9
-rw-r--r--dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild25
-rw-r--r--dev-lisp/cl-inflate/files/digest-cl-inflate-1.1.4.2.11
-rw-r--r--dev-lisp/cl-inflate/files/inflate.asd37
5 files changed, 74 insertions, 6 deletions
diff --git a/dev-lisp/cl-inflate/ChangeLog b/dev-lisp/cl-inflate/ChangeLog
new file mode 100644
index 000000000000..528001fdff22
--- /dev/null
+++ b/dev-lisp/cl-inflate/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/cl-inflate
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-inflate/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+*cl-inflate-1.1.4.2.1 (07 Jul 2003)
+
+ 07 Jul 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ initial import
diff --git a/dev-lisp/cl-inflate/Manifest b/dev-lisp/cl-inflate/Manifest
index 4d20bcb746d5..a5643f1a042c 100644
--- a/dev-lisp/cl-inflate/Manifest
+++ b/dev-lisp/cl-inflate/Manifest
@@ -1,7 +1,4 @@
-MD5 21d80cfb55555c6607055eeb08398b49 ChangeLog 328
-MD5 df6f295e041610543d560d37ad7ad7b6 cl-inflate-1.1.4.2.1.ebuild 688
-MD5 31ae8e06325055aff076689f49ef9362 cl-inflate-1.1.4.2.1.ebuild~ 726
-MD5 dabe9c1f1b838b61486b278782b02463 files/rt.asd 1097
-MD5 b11fa2ad08c93fcf48f585ceed4e8885 files/digest-cl-rt-20030428a 70
-MD5 e66525b63d8bb2a9720c9aff2731f7c8 files/inflate.asd 1236
+MD5 aef490a21ff8f968f338e225ba8123f4 ChangeLog 331
+MD5 c2c44900f839387a6277cebe18fc3169 cl-inflate-1.1.4.2.1.ebuild 800
+MD5 12bbae57ce2e43c7c4585600acc44926 files/inflate.asd 1239
MD5 a2edf99d5162f55b35de68f81c3822e8 files/digest-cl-inflate-1.1.4.2.1 75
diff --git a/dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild b/dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild
new file mode 100644
index 000000000000..a7194b60643e
--- /dev/null
+++ b/dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package to decompress a gzip, jar, and winzip file"
+HOMEPAGE="http://opensource.franz.com/deflate/index.html
+ http://packages.debian.org/unstable/devel/cl-inflate.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-inflate/${PN}_${PV}.orig.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=inflate
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ common-lisp-install inflate.lisp ${FILESDIR}/inflate.asd
+ common-lisp-system-symlink
+}
diff --git a/dev-lisp/cl-inflate/files/digest-cl-inflate-1.1.4.2.1 b/dev-lisp/cl-inflate/files/digest-cl-inflate-1.1.4.2.1
new file mode 100644
index 000000000000..8312f4aa5114
--- /dev/null
+++ b/dev-lisp/cl-inflate/files/digest-cl-inflate-1.1.4.2.1
@@ -0,0 +1 @@
+MD5 d723b009079f22b2a9ba1cdf92aff3b5 cl-inflate_1.1.4.2.1.orig.tar.gz 8458
diff --git a/dev-lisp/cl-inflate/files/inflate.asd b/dev-lisp/cl-inflate/files/inflate.asd
new file mode 100644
index 000000000000..0303c50296e2
--- /dev/null
+++ b/dev-lisp/cl-inflate/files/inflate.asd
@@ -0,0 +1,37 @@
+;;;; -*- Mode: LISP; Syntax: ANSI-Common-Lisp; Base: 10 -*-
+;;;; *************************************************************************
+;;;; FILE IDENTIFICATION
+;;;;
+;;;; Name: inflate.asd
+;;;; Purpose: ASDF definition file for Inflate
+;;;; Programmer: Kevin M. Rosenberg
+;;;; Date Started: Sep 2002
+;;;;
+;;;; $Id: inflate.asd,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+;;;;
+;;;; This file, part of cl-inflate, is Copyright (c) 2002 by Kevin M. Rosenberg
+;;;;
+;;;; cl-inflate users are granted the rights to distribute and use this software
+;;;; as governed by the terms of the GNU Lesser General Public License
+;;;; (http://www.gnu.org/licenses/lgpl.html)
+;;;; *************************************************************************
+
+(in-package :asdf)
+
+#-allegro
+(defsystem :inflate
+ :name "cl-inflate"
+ :author "John Foderaro, Franz, Inc"
+ :version "1.1.4.2"
+ :maintainer "Kevin M. Rosenberg <kmr@debian.org>"
+ :licence "GNU Lesser General Public License"
+ :description "Franz's Inflate compressed files module"
+ :long-description "Inflate decompresses gzip, winzip and jar files."
+
+ :perform (load-op :after (op inflate)
+ (pushnew :inflate cl:*features*))
+
+ :components
+ ((:file "inflate")))
+
+