summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-20 01:26:43 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-20 01:26:43 +0000
commitee8f853c67a60ba3cf29ef4098759daf015c070b (patch)
treee79f966a0d8ccf604f868091f68cbdabaef7e018 /dev-libs
parentVersion bump to 9.1.1. (diff)
downloadgentoo-2-ee8f853c67a60ba3cf29ef4098759daf015c070b.tar.gz
gentoo-2-ee8f853c67a60ba3cf29ef4098759daf015c070b.tar.bz2
gentoo-2-ee8f853c67a60ba3cf29ef4098759daf015c070b.zip
Version bump.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnl/ChangeLog8
-rw-r--r--dev-libs/libnl/files/libnl-1.1.3-offsetof.patch12
-rw-r--r--dev-libs/libnl/libnl-1.1.3.ebuild48
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-libs/libnl/ChangeLog b/dev-libs/libnl/ChangeLog
index ffb858bbb45a..22da410811f5 100644
--- a/dev-libs/libnl/ChangeLog
+++ b/dev-libs/libnl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libnl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.138 2013/03/03 09:03:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.139 2013/03/20 01:26:43 jer Exp $
+
+*libnl-1.1.3 (20 Mar 2013)
+
+ 20 Mar 2013; Jeroen Roovers <jer@gentoo.org> +libnl-1.1.3.ebuild,
+ +files/libnl-1.1.3-offsetof.patch:
+ Version bump.
03 Mar 2013; Mike Frysinger <vapier@gentoo.org> libnl-1.1-r3.ebuild:
Mark s390 stable for libpcap.
diff --git a/dev-libs/libnl/files/libnl-1.1.3-offsetof.patch b/dev-libs/libnl/files/libnl-1.1.3-offsetof.patch
new file mode 100644
index 000000000000..e370a5e62fc6
--- /dev/null
+++ b/dev-libs/libnl/files/libnl-1.1.3-offsetof.patch
@@ -0,0 +1,12 @@
+--- a/include/netlink-local.h
++++ b/include/netlink-local.h
+@@ -343,7 +343,9 @@
+ }
+
+ #define ARRAY_SIZE(X) (sizeof(X) / sizeof((X)[0]))
++#ifndef offsetof
+ #define offsetof(TYPE, MEMBER) ((size_t) &((TYPE *)0)->MEMBER)
++#endif
+
+ #define __init __attribute__ ((constructor))
+ #define __exit __attribute__ ((destructor))
diff --git a/dev-libs/libnl/libnl-1.1.3.ebuild b/dev-libs/libnl/libnl-1.1.3.ebuild
new file mode 100644
index 000000000000..5d8409538457
--- /dev/null
+++ b/dev-libs/libnl/libnl-1.1.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-1.1.3.ebuild,v 1.1 2013/03/20 01:26:43 jer Exp $
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A library for applications dealing with netlink socket"
+HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
+SRC_URI="http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+DOCS=( ChangeLog )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.1-vlan-header.patch \
+ "${FILESDIR}"/${PN}-1.1-flags.patch \
+ "${FILESDIR}"/${PN}-1.1.3-offsetof.patch
+ sed -i \
+ -e '/@echo/d' \
+ Makefile.rules {lib,src,tests}/Makefile || die
+ sed -i \
+ -e 's|-g ||g' \
+ Makefile.opts.in || die
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+
+ if use doc ; then
+ cd "${S}/doc"
+ emake gendoc || die
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ cd "${S}/doc"
+ dohtml -r html/*
+ fi
+}