summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2013-04-15 18:48:55 +0000
committerDaniel Pielmeier <billie@gentoo.org>2013-04-15 18:48:55 +0000
commite65951c0702c4a8e46d1888a4e1269aa5e8d5e2a (patch)
tree520a4f260fb2313046ce103fdbba6e573250c48e /dev-libs
parentVersion bump. Remove old. (diff)
downloadgentoo-2-e65951c0702c4a8e46d1888a4e1269aa5e8d5e2a.tar.gz
gentoo-2-e65951c0702c4a8e46d1888a4e1269aa5e8d5e2a.tar.bz2
gentoo-2-e65951c0702c4a8e46d1888a4e1269aa5e8d5e2a.zip
Works with all versions of tcl/tk of slot 0 without a need to rebuild.
(Portage version: 2.1.11.60/cvs/Linux i686, signed Manifest commit with key 215AD14D)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libisoburn/ChangeLog8
-rw-r--r--dev-libs/libisoburn/libisoburn-1.2.8-r1.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/libisoburn/ChangeLog b/dev-libs/libisoburn/ChangeLog
index 0240acef51d2..312f16f47bab 100644
--- a/dev-libs/libisoburn/ChangeLog
+++ b/dev-libs/libisoburn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libisoburn
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisoburn/ChangeLog,v 1.106 2013/04/13 17:15:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisoburn/ChangeLog,v 1.107 2013/04/15 18:48:55 billie Exp $
+
+*libisoburn-1.2.8-r1 (15 Apr 2013)
+
+ 15 Apr 2013; Daniel Pielmeier <billie@gentoo.org>
+ +libisoburn-1.2.8-r1.ebuild:
+ Works with all versions of tcl/tk of slot 0 without a need to rebuild.
13 Apr 2013; Agostino Sarubbo <ago@gentoo.org> libisoburn-1.2.8.ebuild:
Stable for x86, wrt bug #461100
diff --git a/dev-libs/libisoburn/libisoburn-1.2.8-r1.ebuild b/dev-libs/libisoburn/libisoburn-1.2.8-r1.ebuild
new file mode 100644
index 000000000000..33ae46181c73
--- /dev/null
+++ b/dev-libs/libisoburn/libisoburn-1.2.8-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisoburn/libisoburn-1.2.8-r1.ebuild,v 1.1 2013/04/15 18:48:55 billie Exp $
+
+EAPI=5
+
+DESCRIPTION="Enables creation and expansion of ISO-9660 filesystems on all CD/DVD media supported by libburn"
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="acl cdio debug external-filters external-filters-setuid frontend-optional launch-frontend launch-frontend-setuid readline static-libs xattr zlib"
+
+REQUIRED_USE="frontend-optional? ( || ( launch-frontend launch-frontend-setuid ) )"
+
+RDEPEND=">=dev-libs/libburn-1.2.8
+ >=dev-libs/libisofs-1.2.8
+ readline? ( sys-libs/readline )
+ acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )
+ cdio? ( >=dev-libs/libcdio-0.83 )
+ launch-frontend? ( dev-lang/tcl:0 dev-lang/tk:0 )
+ launch-frontend-setuid? ( dev-lang/tcl:0 dev-lang/tk:0 )
+ frontend-optional? ( dev-tcltk/bwidget )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable readline libreadline) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ $(use_enable cdio libcdio) \
+ $(use_enable external-filters) \
+ $(use_enable external-filters-setuid) \
+ $(use_enable launch-frontend) \
+ $(use_enable launch-frontend-setuid) \
+ --disable-ldconfig-at-install \
+ --enable-pkg-check-modules \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.wiki,startup_file.txt}
+
+ cd "${S}"/xorriso
+ docinto xorriso
+ dodoc changelog.txt README_gnu_xorriso
+
+ find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}