summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-25 16:09:39 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-25 16:09:39 +0000
commitb53a11c4e6b926ea1bd73fe3a85dc2f0ae5ace07 (patch)
treeb79fa8d31c7f82a732acf8b60045ef75c9445a70 /dev-libs
parentStable for HPPA (bug #236971). (diff)
downloadgentoo-2-b53a11c4e6b926ea1bd73fe3a85dc2f0ae5ace07.tar.gz
gentoo-2-b53a11c4e6b926ea1bd73fe3a85dc2f0ae5ace07.tar.bz2
gentoo-2-b53a11c4e6b926ea1bd73fe3a85dc2f0ae5ace07.zip
Revbump. Build shared libraries instead of static.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libtomcrypt/ChangeLog8
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-1.17-r1.ebuild (renamed from dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild)15
2 files changed, 15 insertions, 8 deletions
diff --git a/dev-libs/libtomcrypt/ChangeLog b/dev-libs/libtomcrypt/ChangeLog
index c7b8b7bf205b..ed49d22cd141 100644
--- a/dev-libs/libtomcrypt/ChangeLog
+++ b/dev-libs/libtomcrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libtomcrypt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/ChangeLog,v 1.31 2008/09/25 14:42:36 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/ChangeLog,v 1.32 2008/09/25 16:09:39 hawking Exp $
+
+*libtomcrypt-1.17-r1 (25 Sep 2008)
+
+ 25 Sep 2008; Ali Polatel <hawking@gentoo.org> -libtomcrypt-1.17.ebuild,
+ +libtomcrypt-1.17-r1.ebuild:
+ Revbump. Build shared libraries instead of static.
25 Sep 2008; Ali Polatel <hawking@gentoo.org> metadata.xml:
Add myself to metadata.xml.
diff --git a/dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild b/dev-libs/libtomcrypt/libtomcrypt-1.17-r1.ebuild
index 3b46a911d125..606fdcfb63f3 100644
--- a/dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild
+++ b/dev-libs/libtomcrypt/libtomcrypt-1.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild,v 1.1 2008/06/10 02:58:09 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-1.17-r1.ebuild,v 1.1 2008/09/25 16:09:39 hawking Exp $
inherit flag-o-matic
@@ -28,15 +28,16 @@ src_unpack() {
src_compile() {
use libtommath && append-flags -DLTM_DESC
use tomsfastmath && append-flags -DTFM_DESC
- emake IGNORE_SPEED=1 || die
+ emake -f makefile.shared IGNORE_SPEED=1 || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die
- dodoc TODO changes
+ emake -f makefile.shared DESTDIR="${D}" install ||\
+ die "emake install failed"
+ dodoc TODO changes || die "dodoc failed"
if use doc ; then
- dodoc doc/*
- docinto notes ; dodoc notes/*
- docinto demos ; dodoc demos/*
+ dodoc doc/* || die "dodoc failed"
+ docinto notes ; dodoc notes/* || die "dodoc failed"
+ docinto demos ; dodoc demos/* || die "dodoc failed"
fi
}