summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-01-03 23:45:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-01-03 23:45:38 +0000
commit7a61fda36f39ed5a9cdb785b1870e348c0727f73 (patch)
treecd375724147cfb8337ec796eeae2b5863eedc8c6 /dev-libs
parentFix build with USE=introspection, bug #350061. Clean up old revisions. (diff)
downloadgentoo-2-7a61fda36f39ed5a9cdb785b1870e348c0727f73.tar.gz
gentoo-2-7a61fda36f39ed5a9cdb785b1870e348c0727f73.tar.bz2
gentoo-2-7a61fda36f39ed5a9cdb785b1870e348c0727f73.zip
Add patch for fix build with uclibc, bug #236671.
(Portage version: 2.2.0_alpha12/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libatasmart/ChangeLog8
-rw-r--r--dev-libs/libatasmart/files/libatasmart-0.17-strpool-uninit.patch12
-rw-r--r--dev-libs/libatasmart/libatasmart-0.17.ebuild8
3 files changed, 24 insertions, 4 deletions
diff --git a/dev-libs/libatasmart/ChangeLog b/dev-libs/libatasmart/ChangeLog
index cc49c83ca42d..735eb6931060 100644
--- a/dev-libs/libatasmart/ChangeLog
+++ b/dev-libs/libatasmart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libatasmart
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libatasmart/ChangeLog,v 1.16 2010/10/29 06:21:49 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libatasmart/ChangeLog,v 1.17 2011/01/03 23:45:37 eva Exp $
+
+ 04 Jan 2011; Gilles Dartiguelongue <eva@gentoo.org> libatasmart-0.17.ebuild,
+ +files/libatasmart-0.17-strpool-uninit.patch:
+ Add patch for fix build with uclibc, bug #236671.
29 Oct 2010; Jeroen Roovers <jer@gentoo.org> libatasmart-0.17.ebuild:
Stable for HPPA (bug #329621).
diff --git a/dev-libs/libatasmart/files/libatasmart-0.17-strpool-uninit.patch b/dev-libs/libatasmart/files/libatasmart-0.17-strpool-uninit.patch
new file mode 100644
index 000000000000..bfb201df7a98
--- /dev/null
+++ b/dev-libs/libatasmart/files/libatasmart-0.17-strpool-uninit.patch
@@ -0,0 +1,12 @@
+diff --git a/strpool.c b/strpool.c
+index 27595d3..c326fc2 100644
+--- a/strpool.c
++++ b/strpool.c
+@@ -435,6 +435,7 @@ static int parse(FILE *in, const char *fname, struct item **rfirst, char **remai
+ rl = 0;
+
+ i->next = NULL;
++ i->suffix_of = NULL;
+
+ if (last)
+ last->next = i;
diff --git a/dev-libs/libatasmart/libatasmart-0.17.ebuild b/dev-libs/libatasmart/libatasmart-0.17.ebuild
index 5c6f2c9657ee..8c2d513d367b 100644
--- a/dev-libs/libatasmart/libatasmart-0.17.ebuild
+++ b/dev-libs/libatasmart/libatasmart-0.17.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libatasmart/libatasmart-0.17.ebuild,v 1.15 2010/10/29 06:21:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libatasmart/libatasmart-0.17.ebuild,v 1.16 2011/01/03 23:45:37 eva Exp $
EAPI="2"
+inherit base
+
DESCRIPTION="Lean and small library for ATA S.M.A.R.T. hard disks"
HOMEPAGE="http://0pointer.de/blog/projects/being-smart.html"
SRC_URI="http://0pointer.de/public/${P}.tar.gz"
@@ -16,6 +18,8 @@ IUSE=""
RDEPEND="sys-fs/udev"
DEPEND="${RDEPEND}"
+PATCHES=("${FILESDIR}/${PN}-0.17-strpool-uninit.patch")
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README || die "dodoc failed"