summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-14 17:37:46 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-14 17:37:46 +0000
commit7879d2ddae5ab3248c17125845d98d4151b47e24 (patch)
treea95c5524de445eb367fafa88c74340ad52d17f00 /dev-libs
parentFix USE=static handling #92557 by Alexander Skwar. (diff)
downloadgentoo-2-7879d2ddae5ab3248c17125845d98d4151b47e24.tar.gz
gentoo-2-7879d2ddae5ab3248c17125845d98d4151b47e24.tar.bz2
gentoo-2-7879d2ddae5ab3248c17125845d98d4151b47e24.zip
fix alpha handling
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog5
-rwxr-xr-xdev-libs/openssl/files/gentoo.config-0.9.7g25
-rw-r--r--dev-libs/openssl/openssl-0.9.7d-r2.ebuild4
-rw-r--r--dev-libs/openssl/openssl-0.9.7g.ebuild5
4 files changed, 27 insertions, 12 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index a23418f42e1e..4d1e55770b5b 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,9 +1,6 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.117 2005/05/12 08:29:05 kloeri Exp $
-
- 12 May 2005; Bryan Østergaard <kloeri@gentoo.org> openssl-0.9.7g.ebuild:
- -alpha as configure is broken.
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.118 2005/05/14 17:37:46 vapier Exp $
11 May 2005; Gustavo Zacarias <gustavoz@gentoo.org> openssl-0.9.7g.ebuild:
Back to ~sparc wrt #92075
diff --git a/dev-libs/openssl/files/gentoo.config-0.9.7g b/dev-libs/openssl/files/gentoo.config-0.9.7g
index 3d6f75bc1e30..abb743551f48 100755
--- a/dev-libs/openssl/files/gentoo.config-0.9.7g
+++ b/dev-libs/openssl/files/gentoo.config-0.9.7g
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-0.9.7g,v 1.1 2005/05/09 06:38:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-0.9.7g,v 1.2 2005/05/14 17:37:46 vapier Exp $
# Openssl doesn't play along nicely with cross-compiling
# like autotools based projects, so let's teach it new tricks.
@@ -16,11 +16,28 @@ system="linux"
# gnu*) system="linux"
#esac
+compiler="gcc"
+if [[ ${CC} == "ccc" ]] ; then
+ compiler=${CC}
+fi
+
machine=""
case ${CHOST%%-*} in
- alphaev56*) machine=alpha+bwx;;
- alphaev[67]*) machine=alpha+bwx;;
- alpha*) machine=alpha;;
+ alphaev56*) machine=alpha+bwx-${compiler};;
+ alphaev[67]*) machine=alpha+bwx-${compiler};;
+ alpha*)
+ # this pretty hack is because we have to make sure we
+ # maintain ABI on the system or things like ssh break
+ currmachine=""
+ if [[ ${ROOT} == "/" ]] && [[ -e /usr/lib/libcrypto.so ]] ; then
+ currmachine=$(strings /usr/lib/libcrypto.so | grep ^linux-alpha | sed -e s:linux-::)
+ fi
+ machine=${currmachine:-alpha-${compiler}}
+
+ # NOTE: drop this crap next time SSL changes ABI #'s
+ [[ ${PV:0:5} != "0.9.7" ]] && machine="plzupdatemekthxbye"
+ ;;
+
arm*eb*) machine="elf-arm -DB_ENDIAN";;
arm*) machine="elf-arm -DL_ENDIAN";;
# hppa64*) machine=parisc64;;
diff --git a/dev-libs/openssl/openssl-0.9.7d-r2.ebuild b/dev-libs/openssl/openssl-0.9.7d-r2.ebuild
index ff7b6c326e92..d4c26664cd1d 100644
--- a/dev-libs/openssl/openssl-0.9.7d-r2.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7d-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7d-r2.ebuild,v 1.15 2005/05/09 06:37:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7d-r2.ebuild,v 1.16 2005/05/14 17:37:46 vapier Exp $
-inherit eutils flag-o-matic gcc
+inherit eutils flag-o-matic toolchain-funcs
OLD_096_P="${PN}-0.9.6m"
diff --git a/dev-libs/openssl/openssl-0.9.7g.ebuild b/dev-libs/openssl/openssl-0.9.7g.ebuild
index ac1c3fbf5475..d4d6841894f0 100644
--- a/dev-libs/openssl/openssl-0.9.7g.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7g.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7g.ebuild,v 1.7 2005/05/12 08:29:05 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7g.ebuild,v 1.8 2005/05/14 17:37:46 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -10,7 +10,8 @@ SRC_URI="mirror://openssl/source/${P}.tar.gz"
LICENSE="openssl"
SLOT="0"
-KEYWORDS="-alpha ~amd64 ~arm ~hppa -ia64 ~m68k -mips ~ppc -ppc64 ~s390 ~sh ~sparc ~x86"
+# ia64 is ABI incompat atm, do not change the KEYWORD
+KEYWORDS="~alpha ~amd64 ~arm ~hppa -ia64 ~m68k -mips ~ppc -ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="emacs test bindist"
RDEPEND=""