summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-09-04 10:20:19 +0000
committerPacho Ramos <pacho@gentoo.org>2014-09-04 10:20:19 +0000
commit73242f907a88341647462fe34d4ddd0c6d8e34c5 (patch)
treeeacfe0fb0d60e417e15169de011c6a779c7b15b7 /dev-libs
parentUnmask dev-lang/gforth, build-time bugs are fixed now (diff)
downloadgentoo-2-73242f907a88341647462fe34d4ddd0c6d8e34c5.tar.gz
gentoo-2-73242f907a88341647462fe34d4ddd0c6d8e34c5.tar.bz2
gentoo-2-73242f907a88341647462fe34d4ddd0c6d8e34c5.zip
Version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libsigc++/ChangeLog7
-rw-r--r--dev-libs/libsigc++/libsigc++-2.3.2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-libs/libsigc++/ChangeLog b/dev-libs/libsigc++/ChangeLog
index 99d53eb39924..b7953525e449 100644
--- a/dev-libs/libsigc++/ChangeLog
+++ b/dev-libs/libsigc++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libsigc++
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.191 2014/04/26 06:57:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.192 2014/09/04 10:20:19 pacho Exp $
+
+*libsigc++-2.3.2 (04 Sep 2014)
+
+ 04 Sep 2014; Pacho Ramos <pacho@gentoo.org> +libsigc++-2.3.2.ebuild:
+ Version bump
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -libsigc++-2.2.10.ebuild,
-libsigc++-2.2.11.ebuild:
diff --git a/dev-libs/libsigc++/libsigc++-2.3.2.ebuild b/dev-libs/libsigc++/libsigc++-2.3.2.ebuild
new file mode 100644
index 000000000000..b270fd171a6e
--- /dev/null
+++ b/dev-libs/libsigc++/libsigc++-2.3.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.3.2.ebuild,v 1.1 2014/09/04 10:20:19 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 flag-o-matic
+
+DESCRIPTION="Typesafe callback system for standard C++"
+HOMEPAGE="http://libsigc.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND=""
+DEPEND="sys-devel/m4"
+# Needs mm-common for eautoreconf
+
+src_prepare() {
+ # don't waste time building examples
+ sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' \
+ Makefile.am Makefile.in || die "sed examples failed"
+
+ # don't waste time building tests unless USE=test
+ if ! use test ; then
+ sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' \
+ Makefile.am Makefile.in || die "sed tests failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ filter-flags -fno-exceptions
+
+ gnome2_src_configure \
+ $(use_enable doc documentation) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}