summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-11 23:54:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-11 23:54:43 +0000
commit4df1a3e521bee1e05d302689421fbd30b6991615 (patch)
tree9cc5f7bfdf6ea8b623a22136cbe6add798f9d417 /dev-libs
parentperl is not a RDEPEND and is an optional DEPEND. (diff)
downloadgentoo-2-4df1a3e521bee1e05d302689421fbd30b6991615.tar.gz
gentoo-2-4df1a3e521bee1e05d302689421fbd30b6991615.tar.bz2
gentoo-2-4df1a3e521bee1e05d302689421fbd30b6991615.zip
Bump to 2.4.2. Finally fix parallel installation issues.
(Portage version: 2.2_rc11/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gmime/ChangeLog7
-rw-r--r--dev-libs/gmime/gmime-2.4.2.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-libs/gmime/ChangeLog b/dev-libs/gmime/ChangeLog
index 6a276dd67c39..59d0bd020d81 100644
--- a/dev-libs/gmime/ChangeLog
+++ b/dev-libs/gmime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gmime
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.75 2008/10/04 16:26:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.76 2008/10/11 23:54:43 eva Exp $
+
+*gmime-2.4.2 (11 Oct 2008)
+
+ 11 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> +gmime-2.4.2.ebuild:
+ Bump to 2.4.2. Finally fix parallel installation issues.
04 Oct 2008; Jeroen Roovers <jer@gentoo.org> gmime-2.2.17.ebuild:
Stable for HPPA (bug 229709).
diff --git a/dev-libs/gmime/gmime-2.4.2.ebuild b/dev-libs/gmime/gmime-2.4.2.ebuild
new file mode 100644
index 000000000000..ae599671facd
--- /dev/null
+++ b/dev-libs/gmime/gmime-2.4.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.2.ebuild,v 1.1 2008/10/11 23:54:43 eva Exp $
+
+inherit gnome2 eutils mono libtool
+
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/"
+
+SLOT="2.4"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc mono"
+
+RDEPEND=">=dev-libs/glib-2.12
+ mono? ( dev-lang/mono
+ >=dev-dotnet/gtk-sharp-2.4.0 )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ >=dev-util/gtk-doc-1.0
+ app-text/docbook-sgml-utils )"
+
+DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS PORTING README TODO doc/html/"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use doc ; then
+ #db2html should be docbook2html
+ sed -i -e 's:db2html:docbook2html -o gmime-tut:g' \
+ docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
+ || die "sed failed (1)"
+ # Fix doc targets (bug #97154)
+ sed -i -e 's!\<\(tmpl-build.stamp\): !\1 $(srcdir)/tmpl/*.sgml: !' \
+ gtk-doc.make docs/reference/Makefile.in || die "sed failed (3)"
+ fi
+
+ # Use correct libdir for mono assembly
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -e 's:^prefix=:exec_prefix=:' \
+ -e 's:prefix)/lib:libdir):' \
+ mono/gmime-sharp-2.4.pc.in mono/Makefile.{am,in} || die "sed failed (2)"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable mono) $(use_enable doc gtk-doc)
+ MONO_PATH="${S}" emake || die "emake failed"
+}
+
+src_install() {
+ emake GACUTIL_FLAGS="/root '${D}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" \
+ DESTDIR="${D}" install || die "installation failed"
+
+ if use doc ; then
+ # we don't use docinto/dodoc, because we don't want html doc gzipped
+ insinto /usr/share/doc/${PF}/tutorial
+ doins docs/tutorial/html/*
+ fi
+
+ # rename these two, so they don't conflict with app-arch/sharutils
+ # (bug #70392) Ticho, 2004-11-10
+ mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode-${SLOT}"
+ mv "${D}/usr/bin/uudecode" "${D}/usr/bin/gmime-uudecode-${SLOT}"
+}