summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-31 08:58:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-31 08:58:47 +0000
commit63d0d50210da469495daf5097476ef17e50972f5 (patch)
tree5ce1fddf45a2a81504747e0e12a15a45c87b947f /dev-libs/yaz
parentInvalid headers. Invalid entries. (diff)
downloadgentoo-2-63d0d50210da469495daf5097476ef17e50972f5.tar.gz
gentoo-2-63d0d50210da469495daf5097476ef17e50972f5.tar.bz2
gentoo-2-63d0d50210da469495daf5097476ef17e50972f5.zip
Bug #277853: version bump. Thanks to John Klehm <xixsimplicityxix@gmail.com>.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/yaz')
-rw-r--r--dev-libs/yaz/ChangeLog11
-rw-r--r--dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch25
-rw-r--r--dev-libs/yaz/yaz-3.0.47.ebuild57
3 files changed, 91 insertions, 2 deletions
diff --git a/dev-libs/yaz/ChangeLog b/dev-libs/yaz/ChangeLog
index 2b458a2e32ca..830cefcc3efe 100644
--- a/dev-libs/yaz/ChangeLog
+++ b/dev-libs/yaz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/yaz
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.56 2009/01/05 21:46:11 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.57 2009/07/31 08:58:47 robbat2 Exp $
+
+*yaz-3.0.47 (31 Jul 2009)
+
+ 31 Jul 2009; Robin H. Johnson <robbat2@gentoo.org> +yaz-3.0.47.ebuild,
+ +files/yaz-3.0.47-icu-automagic.patch:
+ Bug #277853: version bump. Thanks to John Klehm
+ <xixsimplicityxix@gmail.com>.
05 Jan 2009; Markus Meier <maekke@gentoo.org> metadata.xml:
drop local icu USE-flag description, as it's global now
diff --git a/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch b/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch
new file mode 100644
index 000000000000..a0aedfe05105
--- /dev/null
+++ b/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch
@@ -0,0 +1,25 @@
+--- yaz-3.0.47/configure.ac.orig 2009-07-08 04:58:43.000000000 -0700
++++ yaz-3.0.47/configure.ac 2009-07-31 01:46:21.764545198 -0700
+@@ -367,14 +367,14 @@
+
+ dnl
+ dnl
+-AC_CHECK_ICU([3.4],[
+- if test "$xml_enabled" = "true"; then
+- ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"
+- else
+- ICU_CPPFLAGS=""
+- AC_MSG_WARN([ICU support disabled because XML support is unavailable])
+- fi
+-])
++dnl ------ ICU
++AC_ARG_ENABLE(icu, [ --enable-icu enable ICU support],[enable_icu=$enableval],[enable_icu=no])
++if test "$enable_icu" = "yes"; then
++ AC_CHECK_ICU([3.4],[
++ ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"],[
++ AC_MSG_ERROR([For ICU support please install libicu34-dev or similar])
++ ])
++fi
+ dnl
+ dnl ------ Memory debugging
+ AC_ARG_ENABLE([memdebug],[ --enable-memdebug enable memory debugging],[enable_memdebug=$enableval],[enable_memdebug=none])
diff --git a/dev-libs/yaz/yaz-3.0.47.ebuild b/dev-libs/yaz/yaz-3.0.47.ebuild
new file mode 100644
index 000000000000..f7f818e330e1
--- /dev/null
+++ b/dev-libs/yaz/yaz-3.0.47.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-3.0.47.ebuild,v 1.1 2009/07/31 08:58:47 robbat2 Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/yaz"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug icu tcpd ziffy"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/openssl
+ icu? ( dev-libs/icu )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ziffy? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/tcl
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.47-icu-automagic.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_enable debug memdebug) \
+ $(use_enable icu) \
+ $(use_enable tcpd tcpd /usr)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="/usr/share/doc/${PF}"
+ emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+
+ dodir ${docdir}/html
+ mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc ChangeLog NEWS README
+}