summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-08 13:41:46 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-08 13:41:46 +0000
commit0dcc52388722889d7ee99d4a66adf9de29ac0151 (patch)
tree4a0bbd691e19598c81cd57da9de8a52c82098238 /dev-libs/yaz++
parentBump (diff)
downloadgentoo-2-0dcc52388722889d7ee99d4a66adf9de29ac0151.tar.gz
gentoo-2-0dcc52388722889d7ee99d4a66adf9de29ac0151.tar.bz2
gentoo-2-0dcc52388722889d7ee99d4a66adf9de29ac0151.zip
Bump
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/yaz++')
-rw-r--r--dev-libs/yaz++/ChangeLog7
-rw-r--r--dev-libs/yaz++/yaz++-1.1.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-libs/yaz++/ChangeLog b/dev-libs/yaz++/ChangeLog
index 70145d4b33d0..a587120e8f02 100644
--- a/dev-libs/yaz++/ChangeLog
+++ b/dev-libs/yaz++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/yaz++
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz++/ChangeLog,v 1.7 2009/10/04 14:43:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz++/ChangeLog,v 1.8 2009/11/08 13:41:46 patrick Exp $
+
+*yaz++-1.1.4 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +yaz++-1.1.4.ebuild:
+ Bump
04 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> yaz++-1.1.0.ebuild:
Replace -Wl,--no-as-needed with function from flag-o-matic eclass.
diff --git a/dev-libs/yaz++/yaz++-1.1.4.ebuild b/dev-libs/yaz++/yaz++-1.1.4.ebuild
new file mode 100644
index 000000000000..6e2f9317e517
--- /dev/null
+++ b/dev-libs/yaz++/yaz++-1.1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz++/yaz++-1.1.4.ebuild,v 1.1 2009/11/08 13:41:46 patrick Exp $
+
+inherit eutils autotools flag-o-matic
+
+MY_PN=${PN/++/pp}
+
+DESCRIPTION="C++ addon for the yaz development libraries"
+HOMEPAGE="http://www.indexdata.dk/yazplusplus"
+SRC_URI="http://ftp.indexdata.dk/pub/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/yaz-3.0.26"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ append-ldflags $(no-as-needed)
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ docdir="/usr/share/doc/${PF}"
+ emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+
+ dodoc ChangeLog NEWS README TODO
+ docinto html
+ mv -f "${D}"/${docdir}/*.html "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${D}"/usr/share/doc/${MY_PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${D}"/usr/share/doc/${MY_PN}
+}