summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-04-25 19:38:48 +0000
committerMichael Weber <xmw@gentoo.org>2013-04-25 19:38:48 +0000
commitbb64d19f8a799662520a7e1181106d9206c4048d (patch)
treec6882f285c59dd5e08fc8fe91b4f7b3f2e179225 /dev-libs/yajl/yajl-2.0.4-r1.ebuild
parentBumping verison to 1.9.0. We're relying on the internal static build of qt no... (diff)
downloadgentoo-2-bb64d19f8a799662520a7e1181106d9206c4048d.tar.gz
gentoo-2-bb64d19f8a799662520a7e1181106d9206c4048d.tar.bz2
gentoo-2-bb64d19f8a799662520a7e1181106d9206c4048d.zip
revbump to cmake-multilib, add myself as maint (bug 466820)
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-libs/yajl/yajl-2.0.4-r1.ebuild')
-rw-r--r--dev-libs/yajl/yajl-2.0.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/yajl/yajl-2.0.4-r1.ebuild b/dev-libs/yajl/yajl-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..3d4ca19d1be5
--- /dev/null
+++ b/dev-libs/yajl/yajl-2.0.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-2.0.4-r1.ebuild,v 1.1 2013/04/25 19:38:48 xmw Exp $
+
+EAPI=5
+
+inherit base cmake-multilib
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="http://lloyd.github.com/yajl/"
+SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix_static_linking.patch
+)
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/lloyd-${PN}-* "${S}"
+}
+
+src_test() {
+ emake -C ${CMAKE_BUILD_DIR} test
+}