summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2012-02-10 17:15:56 +0000
committerMatt Turner <mattst88@gentoo.org>2012-02-10 17:15:56 +0000
commit1e7908e669274997aee86db44da018b0ea9e505d (patch)
tree85cfe6a2628a73050858cdf6675dd64b5433af8c /dev-libs/wayland
parentAdd leechcraft-gacts plugin, by 0xd34df00d (diff)
downloadgentoo-2-1e7908e669274997aee86db44da018b0ea9e505d.tar.gz
gentoo-2-1e7908e669274997aee86db44da018b0ea9e505d.tar.bz2
gentoo-2-1e7908e669274997aee86db44da018b0ea9e505d.zip
First version of wayland in portage.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/ChangeLog10
-rw-r--r--dev-libs/wayland/Manifest4
-rw-r--r--dev-libs/wayland/metadata.xml5
-rw-r--r--dev-libs/wayland/wayland-0.85.0.ebuild46
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
new file mode 100644
index 000000000000..6e4f148300da
--- /dev/null
+++ b/dev-libs/wayland/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/wayland
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.1 2012/02/10 17:15:56 mattst88 Exp $
+
+*wayland-0.85.0 (10 Feb 2012)
+
+ 10 Feb 2012; Matt Turner <mattst88@gentoo.org> +wayland-0.85.0.ebuild,
+ +metadata.xml:
+ First version of wayland in portage.
+
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
new file mode 100644
index 000000000000..2dbb5f1782a4
--- /dev/null
+++ b/dev-libs/wayland/Manifest
@@ -0,0 +1,4 @@
+DIST wayland-0.85.0.tar.xz 224496 RMD160 450d4ff30b7de30b7842bf69cff10395028b0a87 SHA1 8114f244603a106fbf28ffd92e537acdd0b29a8b SHA256 9e3d4579916e963a77a59c90b4524c1d28aca2654ec76907c7cd58cf4c5cbc30
+EBUILD wayland-0.85.0.ebuild 913 RMD160 f0f29a778d48fa5e8e2b189795b9a7f7378aac4d SHA1 be26712d73788959a4ec4b530a32015115afbe8b SHA256 2cb3732ab47093acf65773a8127893e0960e37239d6247ba0f5ea6cb6b0af615
+MISC ChangeLog 278 RMD160 e99419b0db4d4355fba9a622e9728f25da9c0ba1 SHA1 e68e9f9b796e376a1af570a665419db42559d873 SHA256 1bc0f0329b25f4624b278ae9f880d6d35593283c65db7d925fdca0848eea8b96
+MISC metadata.xml 156 RMD160 c1274bdccf57603d580de0075ba07a35b7509560 SHA1 6f78f604e3d079d39189b40aaaa1ddb06182ad91 SHA256 5101ab0d4cc8c7125eea733c44e86962769bd77acaf53b69223b9cadcdd29055
diff --git a/dev-libs/wayland/metadata.xml b/dev-libs/wayland/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/dev-libs/wayland/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/dev-libs/wayland/wayland-0.85.0.ebuild b/dev-libs/wayland/wayland-0.85.0.ebuild
new file mode 100644
index 000000000000..0bcce7bb321d
--- /dev/null
+++ b/dev-libs/wayland/wayland-0.85.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-0.85.0.ebuild,v 1.1 2012/02/10 17:15:56 mattst88 Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/expat
+ dev-libs/libffi"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ if tc-is-cross-compiler ; then
+ econf $(use_enable static-libs static) --disable-scanner
+ else
+ econf $(use_enable static-libs static)
+ fi
+}