summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-09-07 22:06:06 +0000
committerJason Wever <weeve@gentoo.org>2003-09-07 22:06:06 +0000
commit1ef7e9ef7908a9ea99f84abe1c39a7e197c5073c (patch)
tree5b2fd04d6924d0c42784cb0de43e62dd0c668c1f /dev-libs/slib/slib-2.4.6.ebuild
parentVersion bump. Fixes bug #26482. (diff)
downloadgentoo-2-1ef7e9ef7908a9ea99f84abe1c39a7e197c5073c.tar.gz
gentoo-2-1ef7e9ef7908a9ea99f84abe1c39a7e197c5073c.tar.bz2
gentoo-2-1ef7e9ef7908a9ea99f84abe1c39a7e197c5073c.zip
Version bump. Fixes bug #26482.
Diffstat (limited to 'dev-libs/slib/slib-2.4.6.ebuild')
-rw-r--r--dev-libs/slib/slib-2.4.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/slib/slib-2.4.6.ebuild b/dev-libs/slib/slib-2.4.6.ebuild
new file mode 100644
index 000000000000..86f6a6016c68
--- /dev/null
+++ b/dev-libs/slib/slib-2.4.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/slib/slib-2.4.6.ebuild,v 1.1 2003/09/07 22:06:00 weeve Exp $
+
+MY_P=${PN}2d6
+S=${WORKDIR}/${PN}
+DESCRIPTION="library providing functions for Scheme implementations"
+SRC_URI="http://swissnet.ai.mit.edu/ftpdir/scm/${MY_P}.zip"
+HOMEPAGE="http://swissnet.ai.mit.edu/~jaffer/SLIB.html"
+
+SLOT="0"
+LICENSE="public-domain BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND=">=dev-util/guile-1.4"
+DEPEND="${RDEPEND}
+ >=app-arch/unzip-5.21
+ >=dev-util/guile-1.4"
+
+src_install() {
+ insinto /usr/share/guile/site/slib
+ doins *.scm
+ dodoc ANNOUNCE ChangeLog FAQ README
+ doinfo slib.info
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ einfo "Installing..."
+ guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)" "/"
+ fi
+}