summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-16 09:03:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-16 09:03:02 +0000
commitea92c70426ed1484cb36a7628aeadffe600415bb (patch)
treea94a03aeeeb0e38a740c39c47111081334c95a81 /dev-libs/redland
parentminor license fix, it comes with GPL-2 too although LICENSE.txt says different (diff)
downloadgentoo-2-ea92c70426ed1484cb36a7628aeadffe600415bb.tar.gz
gentoo-2-ea92c70426ed1484cb36a7628aeadffe600415bb.tar.bz2
gentoo-2-ea92c70426ed1484cb36a7628aeadffe600415bb.zip
Version bump.
(Portage version: 2.2_rc96/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/redland')
-rw-r--r--dev-libs/redland/ChangeLog8
-rw-r--r--dev-libs/redland/redland-1.0.12.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-libs/redland/ChangeLog b/dev-libs/redland/ChangeLog
index b6dcb8e58ff7..29e907786722 100644
--- a/dev-libs/redland/ChangeLog
+++ b/dev-libs/redland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/redland
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.73 2010/07/18 19:55:47 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.74 2010/10/16 09:03:02 ssuominen Exp $
+
+*redland-1.0.12 (16 Oct 2010)
+
+ 16 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +redland-1.0.12.ebuild:
+ Version bump.
18 Jul 2010; Tomáš Chvátal <scarabeus@gentoo.org>
redland-1.0.10-r2.ebuild:
diff --git a/dev-libs/redland/redland-1.0.12.ebuild b/dev-libs/redland/redland-1.0.12.ebuild
new file mode 100644
index 000000000000..582fd69a2bed
--- /dev/null
+++ b/dev-libs/redland/redland-1.0.12.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/redland-1.0.12.ebuild,v 1.1 2010/10/16 09:03:02 ssuominen Exp $
+
+EAPI=3
+inherit libtool
+
+DESCRIPTION="High-level interface for the Resource Description Framework"
+HOMEPAGE="http://librdf.org/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE="berkdb iodbc mysql odbc postgres sqlite ssl static-libs xml"
+
+# libltdl is used for loading plugins, don't remove .la files
+RDEPEND=">=sys-devel/libtool-2.2.6
+ mysql? ( virtual/mysql )
+ sqlite? ( =dev-db/sqlite-3* )
+ berkdb? ( sys-libs/db )
+ xml? ( dev-libs/libxml2 )
+ !xml? ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ >=media-libs/raptor-1.9.0
+ >=dev-libs/rasqal-0.9.20
+ postgres? ( dev-db/postgresql-base )
+ iodbc? ( dev-db/libiodbc )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ local parser=expat
+ use xml && parser=libxml
+
+ local myconf="--without-virtuoso"
+ if use iodbc; then
+ myconf="--with-virtuoso --with-iodbc --without-unixodbc"
+ elif use odbc; then
+ myconf="--with-virtuoso --with-unixodbc --without-iodbc"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ --enable-raptor2 \
+ $(use_with berkdb bdb) \
+ --with-xml-parser=${parser} \
+ $(use_with ssl openssl-digests) \
+ $(use_with mysql) \
+ $(use_with sqlite) \
+ $(use_with postgres postgresql) \
+ --without-threads \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ ${myconf}
+}
+
+src_test() {
+ if ! use berkdb; then
+ export REDLAND_TEST_CLONING_STORAGE_TYPE=hashes
+ export REDLAND_TEST_CLONING_STORAGE_NAME=test
+ export REDLAND_TEST_CLONING_STORAGE_OPTIONS="hash-type='memory',dir='.',write='yes',new='yes',contexts='yes'"
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml {FAQS,NEWS,README,RELEASE,TODO}.html
+}