summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrzemyslaw Maciag <troll@gentoo.org>2007-03-14 21:40:21 +0000
committerPrzemyslaw Maciag <troll@gentoo.org>2007-03-14 21:40:21 +0000
commitcb53a15ec1137956b8572ef189f23b8fb2560657 (patch)
tree99448232110b8195d7b621521a795848cf86f2cb /dev-libs/qsa/qsa-1.1.1.ebuild
parentFix broken init script syntax (#170916). (diff)
downloadgentoo-2-cb53a15ec1137956b8572ef189f23b8fb2560657.tar.gz
gentoo-2-cb53a15ec1137956b8572ef189f23b8fb2560657.tar.bz2
gentoo-2-cb53a15ec1137956b8572ef189f23b8fb2560657.zip
Ebuild cleanup - moved patching to src_unpack. Version bump to 1.1.5
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-libs/qsa/qsa-1.1.1.ebuild')
-rw-r--r--dev-libs/qsa/qsa-1.1.1.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/dev-libs/qsa/qsa-1.1.1.ebuild b/dev-libs/qsa/qsa-1.1.1.ebuild
index f6a3c817ed3d..bd69d6d2eef3 100644
--- a/dev-libs/qsa/qsa-1.1.1.ebuild
+++ b/dev-libs/qsa/qsa-1.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qsa/qsa-1.1.1.ebuild,v 1.8 2006/12/14 23:01:24 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qsa/qsa-1.1.1.ebuild,v 1.9 2007/03/14 21:40:21 troll Exp $
inherit eutils qt3
@@ -14,17 +14,15 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="doc examples ide threads"
+
DEPEND="$(qt_min_version 3.2)"
+RDEPEND="${DEPEND}"
-src_compile() {
- local myconf="-prefix ${D}${QTDIR}"
+src_unpack() {
+ unpack ${A}
- use threads && myconf="${myconf} -thread"
-
- if ! use ide; then
- myconf="${myconf} -no-ide"
- epatch ${FILESDIR}/${P}-without-examples-using-ide.diff
- fi
+ cd ${S}
+ ! use ide && epatch ${FILESDIR}/${P}-without-examples-using-ide.diff
if use examples; then
epatch ${FILESDIR}/${P}-with-examples.diff
@@ -34,9 +32,17 @@ src_compile() {
fi
epatch ${FILESDIR}/${P}-sandbox-fix.diff
+}
+
+src_compile() {
+ local myconf="-prefix ${D}${QTDIR}"
+
+ use threads && myconf="${myconf} -thread"
+ ! use ide && myconf="${myconf} -no-ide"
+
+ ./configure ${myconf} || die "configure failed"
- ./configure ${myconf} || die
- emake || die
+ emake || die "make failed"
}
src_install() {