summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-09-03 19:26:58 +0000
committerThomas Sachau <tommy@gentoo.org>2013-09-03 19:26:58 +0000
commit9bfbd2e3aa516f56c76cd2f9353398d69d794494 (patch)
treece7afd26e8d29a09cef673b3c0c0073bc8a56a9a /dev-libs/poco
parentBump KDE to 4.1.1 (diff)
downloadgentoo-2-9bfbd2e3aa516f56c76cd2f9353398d69d794494.tar.gz
gentoo-2-9bfbd2e3aa516f56c76cd2f9353398d69d794494.tar.bz2
gentoo-2-9bfbd2e3aa516f56c76cd2f9353398d69d794494.zip
Add missing patch
(Portage version: 2.2.1-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'dev-libs/poco')
-rw-r--r--dev-libs/poco/ChangeLog6
-rw-r--r--dev-libs/poco/files/1.4.6_p1-gentoo.patch74
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-libs/poco/ChangeLog b/dev-libs/poco/ChangeLog
index 3c175b9b9152..348ad0aa8059 100644
--- a/dev-libs/poco/ChangeLog
+++ b/dev-libs/poco/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/poco
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/poco/ChangeLog,v 1.22 2013/09/01 11:14:43 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/poco/ChangeLog,v 1.23 2013/09/03 19:26:58 tommy Exp $
+
+ 03 Sep 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +files/1.4.6_p1-gentoo.patch:
+ Add missing patch
*poco-1.4.6_p1 (01 Sep 2013)
diff --git a/dev-libs/poco/files/1.4.6_p1-gentoo.patch b/dev-libs/poco/files/1.4.6_p1-gentoo.patch
new file mode 100644
index 000000000000..243ee924b16b
--- /dev/null
+++ b/dev-libs/poco/files/1.4.6_p1-gentoo.patch
@@ -0,0 +1,74 @@
+diff -Nur poco-1.4.5-all_old/components poco-1.4.5-all/components
+--- poco-1.4.5-all_old/components 2012-11-18 16:56:59.000000000 +0100
++++ poco-1.4.5-all/components 2012-12-06 12:29:07.779546771 +0100
+@@ -1,14 +1,8 @@
+-CppUnit
+ Foundation
+ XML
+ Util
+ Net
+-Crypto
+-NetSSL_OpenSSL
+ Data
+-Data/SQLite
+-Data/ODBC
+-Data/MySQL
+ Zip
+ PageCompiler
+ PageCompiler/File2Page
+diff -Nur poco-1.4.5-all_old/Data/ODBC/ODBC.make poco-1.4.5-all/Data/ODBC/ODBC.make
+--- poco-1.4.5-all_old/Data/ODBC/ODBC.make 2012-11-18 16:56:57.000000000 +0100
++++ poco-1.4.5-all/Data/ODBC/ODBC.make 2012-12-06 12:29:07.779546771 +0100
+@@ -14,9 +14,9 @@
+ ifeq (0, $(shell test -d /usr/lib/$(OSARCH)-linux-gnu; echo $$?))
+ ODBCLIBDIR = /usr/lib/$(OSARCH)-linux-gnu
+ else ifeq (0, $(shell test -d /usr/lib64; echo $$?))
+-ODBCLIBDIR = /usr/lib64
++ODBCLIBDIR = /usr/$(LIBDIR)
+ else
+-ODBCLIBDIR = /usr/lib
++ODBCLIBDIR = /usr/$(LIBDIR)
+ endif
+ endif
+
+@@ -39,10 +39,10 @@
+ CXXFLAGS += -DODBCVER=0x0300 -DNOMINMAX
+ # CYGWIN platform has its own ODBC library in /lib/w32api
+ SYSLIBS += -L/lib/w32api -lodbc32 -lodbccp32
+-else ifeq (0, $(shell test -e $(ODBCLIBDIR)/libodbc$(LIBLINKEXT); echo $$?))
++else ifeq (unixodbc, $(GENTOO_ODBC))
+ SYSLIBS += -lodbc -lodbcinst
+ COMMONFLAGS += -DPOCO_UNIXODBC
+-else ifeq (0, $(shell test -e $(ODBCLIBDIR)/libiodbc$(LIBLINKEXT); echo $$?))
++else ifeq (unixodbc, $(GENTOO_ODBC))
+ SYSLIBS += -liodbc -liodbcinst
+ COMMONFLAGS += -DPOCO_IODBC -I/usr/include/iodbc
+ else
+diff -Nur poco-1.4.5-all_old/Makefile poco-1.4.5-all/Makefile
+--- poco-1.4.5-all_old/Makefile 2012-11-18 16:57:00.000000000 +0100
++++ poco-1.4.5-all/Makefile 2012-12-06 12:29:07.779546771 +0100
+@@ -33,7 +33,7 @@
+
+ install: libexecs
+ mkdir -p $(INSTALLDIR)/include/Poco
+- mkdir -p $(INSTALLDIR)/lib
++ mkdir -p $(INSTALLDIR)/$(LIBDIR)
+ mkdir -p $(INSTALLDIR)/bin
+ for comp in $(COMPONENTS) ; do \
+ if [ -d "$(POCO_BASE)/$$comp/include" ] ; then \
+@@ -43,11 +43,11 @@
+ find $(POCO_BUILD)/$$comp/bin -perm -700 -type f -exec cp -f {} $(INSTALLDIR)/bin \; ; \
+ fi ; \
+ done
+- find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
+- find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
++ find $(POCO_BUILD)/$(LIBDIR) -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/$(LIBDIR) \;
++ find $(POCO_BUILD)/$(LIBDIR) -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/$(LIBDIR) \;
+
+-libexecs = Foundation-libexec XML-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
+-tests = Foundation-tests XML-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests Zip-tests
++libexecs = Foundation-libexec XML-libexec Util-libexec Net-libexec Data-libexec Zip-libexec PageCompiler-libexec
++tests = Foundation-tests XML-tests Util-tests Net-tests Data-tests Zip-tests
+ samples = Foundation-samples XML-samples Util-samples Net-samples Crypto-samples NetSSL_OpenSSL-samples Data-samples Zip-samples PageCompiler-samples
+
+ .PHONY: $(libexecs)