summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-27 22:26:11 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-27 22:26:11 +0000
commite241ddccde3357ad2da85aedf4943dfff6215a29 (patch)
tree8f34c7832060127103d0781e3981aa00a6ba77c1 /dev-libs/nettle
parentRemove old versions. (diff)
downloadgentoo-2-e241ddccde3357ad2da85aedf4943dfff6215a29.tar.gz
gentoo-2-e241ddccde3357ad2da85aedf4943dfff6215a29.tar.bz2
gentoo-2-e241ddccde3357ad2da85aedf4943dfff6215a29.zip
Version bump (bug #467468), add neon use flag.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/ChangeLog8
-rw-r--r--dev-libs/nettle/files/nettle-2.7-shared.patch77
-rw-r--r--dev-libs/nettle/nettle-2.7.ebuild51
3 files changed, 135 insertions, 1 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index e19ea6330045..a904538e70ba 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.88 2013/03/15 15:25:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.89 2013/04/27 22:26:11 radhermit Exp $
+
+*nettle-2.7 (27 Apr 2013)
+
+ 27 Apr 2013; Tim Harder <radhermit@gentoo.org> +nettle-2.7.ebuild,
+ +files/nettle-2.7-shared.patch:
+ Version bump (bug #467468), add neon use flag.
15 Mar 2013; Jeroen Roovers <jer@gentoo.org> nettle-2.6.ebuild:
Stable for HPPA (bug #461104).
diff --git a/dev-libs/nettle/files/nettle-2.7-shared.patch b/dev-libs/nettle/files/nettle-2.7-shared.patch
new file mode 100644
index 000000000000..9b9d6c884d14
--- /dev/null
+++ b/dev-libs/nettle/files/nettle-2.7-shared.patch
@@ -0,0 +1,77 @@
+--- nettle-2.7/examples/Makefile.in
++++ nettle-2.7/examples/Makefile.in
+@@ -8,7 +8,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ OPENSSL_LIBFLAGS = @OPENSSL_LIBFLAGS@
+ BENCH_LIBS = @BENCH_LIBS@ -lm
+@@ -117,8 +117,8 @@
+ -lhogweed -lnettle $(BENCH_LIBS) $(LIBS) $(OPENSSL_LIBFLAGS) \
+ -o hogweed-benchmark$(EXEEXT)
+
+-$(TARGETS) : io.$(OBJEXT) ../libnettle.a
+-$(HOGWEED_TARGETS): ../libhogweed.a
++$(TARGETS) : io.$(OBJEXT) ../$(LIBNETTLE_FORLINK)
++$(HOGWEED_TARGETS): ../$(LIBHOGWEED_FORLINK)
+
+ check: $(TS_ALL)
+ LD_LIBRARY_PATH=../.lib PATH="../.lib:$$PATH" srcdir="$(srcdir)" \
+--- nettle-2.7/testsuite/Makefile.in
++++ nettle-2.7/testsuite/Makefile.in
+@@ -8,7 +8,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ TS_NETTLE_SOURCES = aes-test.c arcfour-test.c arctwo-test.c \
+ blowfish-test.c cast128-test.c \
+@@ -96,7 +96,7 @@
+ include $(srcdir)/.test-rules.make
+
+ $(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) ../nettle-internal.$(OBJEXT) \
+- ../libnettle.a @IF_HOGWEED@ ../libhogweed.a
++ ../$(LIBNETTLE_FORLINK) @IF_HOGWEED@ ../$(LIBHOGWEED_FORLINK)
+
+ # For use as, e.g.,
+ #
+--- nettle-2.7/tools/Makefile.in
++++ nettle-2.7/tools/Makefile.in
+@@ -15,7 +15,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ HOGWEED_TARGETS = pkcs1-conv$(EXEEXT)
+ TARGETS = sexp-conv$(EXEEXT) nettle-hash$(EXEEXT) nettle-lfib-stream$(EXEEXT) \
+@@ -34,19 +34,19 @@
+ DISTFILES = $(SOURCES) Makefile.in input.h misc.h output.h parse.h
+
+ sexp_conv_OBJS = $(sexp_conv_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-sexp-conv$(EXEEXT): $(sexp_conv_OBJS) ../libnettle.a
++sexp-conv$(EXEEXT): $(sexp_conv_OBJS) ../$(LIBNETTLE_FORLINK)
+ $(LINK) $(sexp_conv_OBJS) -lnettle $(LIBS) -o $@
+
+-nettle-lfib-stream$(EXEEXT): nettle-lfib-stream.$(OBJEXT) ../libnettle.a
++nettle-lfib-stream$(EXEEXT): nettle-lfib-stream.$(OBJEXT) ../$(LIBNETTLE_FORLINK)
+ $(LINK) nettle-lfib-stream.$(OBJEXT) -lnettle $(LIBS) -o $@
+
+ pkcs1_conv_OBJS = $(pkcs1_conv_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-pkcs1-conv$(EXEEXT): $(pkcs1_conv_OBJS) ../libnettle.a ../libhogweed.a
++pkcs1-conv$(EXEEXT): $(pkcs1_conv_OBJS) ../$(LIBNETTLE_FORLINK) ../$(LIBHOGWEED_FORLINK)
+ $(LINK) $(pkcs1_conv_OBJS) -lhogweed -lnettle $(LIBS) -o $@
+
+ # FIXME: Avoid linking with gmp
+ nettle_hash_OBJS = $(nettle_hash_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-nettle-hash$(EXEEXT): $(nettle_hash_OBJS) ../libnettle.a
++nettle-hash$(EXEEXT): $(nettle_hash_OBJS) ../$(LIBNETTLE_FORLINK)
+ $(LINK) $(nettle_hash_OBJS) -lnettle $(LIBS) -o $@
+
+
diff --git a/dev-libs/nettle/nettle-2.7.ebuild b/dev-libs/nettle/nettle-2.7.ebuild
new file mode 100644
index 000000000000..f76d932446dd
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.7.ebuild,v 1.1 2013/04/27 22:26:11 radhermit Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0/4" # subslot = libnettle soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +gmp neon static-libs test"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-shared.patch
+
+ sed -e '/CFLAGS=/s: -ggdb3::' \
+ -e 's/solaris\*)/sunldsolaris*)/' \
+ -i configure.ac || die
+
+ # conditionally build tests and examples required by tests
+ use test || sed -i '/SUBDIRS/s/testsuite examples//' Makefile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-openssl bug #427526
+ econf \
+ $(use_enable gmp public-key) \
+ $(use_enable static-libs static) \
+ --disable-openssl \
+ $(use_enable doc documentation) \
+ $(use_enable neon arm-neon)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dohtml nettle.html
+ dodoc nettle.pdf
+ fi
+}