summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-11-06 00:42:20 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-11-06 00:42:20 +0000
commite9aae3e262b1f8ea898dee2531fbb23594d3527f (patch)
treed7bdf6a316c4fafbd1e9667850d7958d7f183285 /dev-libs/mpc
parentHandle distribute_setup module in distutils_src_prepare(). (diff)
downloadgentoo-2-e9aae3e262b1f8ea898dee2531fbb23594d3527f.tar.gz
gentoo-2-e9aae3e262b1f8ea898dee2531fbb23594d3527f.tar.bz2
gentoo-2-e9aae3e262b1f8ea898dee2531fbb23594d3527f.zip
Version bump.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/mpc')
-rw-r--r--dev-libs/mpc/ChangeLog8
-rw-r--r--dev-libs/mpc/files/mpc-0.6-fortify.patch50
-rw-r--r--dev-libs/mpc/mpc-0.8.ebuild (renamed from dev-libs/mpc/mpc-0.6.ebuild)14
3 files changed, 10 insertions, 62 deletions
diff --git a/dev-libs/mpc/ChangeLog b/dev-libs/mpc/ChangeLog
index 36faef638831..fc00a191d82d 100644
--- a/dev-libs/mpc/ChangeLog
+++ b/dev-libs/mpc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/mpc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpc/ChangeLog,v 1.9 2009/10/21 15:19:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpc/ChangeLog,v 1.10 2009/11/06 00:42:18 dirtyepic Exp $
+
+*mpc-0.8 (06 Nov 2009)
+
+ 06 Nov 2009; Ryan Hill <dirtyepic@gentoo.org> -mpc-0.6.ebuild,
+ -files/mpc-0.6-fortify.patch, +mpc-0.8.ebuild:
+ Version bump.
21 Oct 2009; Raúl Porcel <armin76@gentoo.org> mpc-0.7.ebuild:
Add ~ia64/~s390/~sh/~sparc wrt #279851
diff --git a/dev-libs/mpc/files/mpc-0.6-fortify.patch b/dev-libs/mpc/files/mpc-0.6-fortify.patch
deleted file mode 100644
index 50582f765fba..000000000000
--- a/dev-libs/mpc/files/mpc-0.6-fortify.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Fix testsuite failure w/ -D_FORTIFY_SOURCE=2
-http://lists.gforge.inria.fr/pipermail/mpc-discuss/2009-April/000404.html
-
---- mpc-0.6-orig/src/inp_str.c
-+++ mpc-0.6/src/inp_str.c
-@@ -1,6 +1,6 @@
- /* mpc_inp_str -- Input a complex number from a given stream.
-
--Copyright (C) 2009 Andreas Enge, Philippe Th\'eveny, Paul Zimmermann.
-+Copyright (C) 2009 Andreas Enge, Philippe Th\'eveny, Paul Zimmermann
-
- This file is part of the MPC Library.
-
-@@ -80,6 +80,7 @@ extract_string (FILE *stream)
- size_t nread = 0;
- size_t strsize = 100;
- char *str = mpc_alloc_str (strsize);
-+ size_t lenstr;
-
- c = getc (stream);
- while (c != EOF && c != '\n'
-@@ -101,6 +102,8 @@ extract_string (FILE *stream)
- if (nread == 0)
- return str;
-
-+ lenstr = nread;
-+
- if (c == '(') {
- size_t n;
- char *suffix;
-@@ -127,7 +130,7 @@ extract_string (FILE *stream)
- strsize = nread + 1;
- }
-
-- n = sprintf (str, "%s(%s", str, suffix);
-+ n = lenstr + sprintf (str + lenstr, "(%s", suffix);
- MPC_ASSERT (n == nread);
-
- c = getc (stream);
-@@ -151,7 +154,9 @@ extract_string (FILE *stream)
-
-
- int
--mpc_inp_str (mpc_ptr rop, FILE *stream, size_t *read, int base, mpc_rnd_t rnd_mode) {
-+mpc_inp_str (mpc_ptr rop, FILE *stream, size_t *read, int base,
-+mpc_rnd_t rnd_mode)
-+{
- size_t white, nread = 0;
- int inex = -1;
- int c;
diff --git a/dev-libs/mpc/mpc-0.6.ebuild b/dev-libs/mpc/mpc-0.8.ebuild
index e5b90a4c7151..c65f68af217c 100644
--- a/dev-libs/mpc/mpc-0.6.ebuild
+++ b/dev-libs/mpc/mpc-0.8.ebuild
@@ -1,30 +1,22 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpc/mpc-0.6.ebuild,v 1.6 2009/08/28 16:04:38 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpc/mpc-0.8.ebuild,v 1.1 2009/11/06 00:42:18 dirtyepic Exp $
EAPI=0
-inherit eutils
-
DESCRIPTION="A library for multiprecision complex arithmetic with exact rounding."
HOMEPAGE="http://mpc.multiprecision.org/"
SRC_URI="http://www.multiprecision.org/mpc/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""
-DEPEND=">=dev-libs/gmp-4.1.3
+DEPEND=">=dev-libs/gmp-4.2.3
>=dev-libs/mpfr-2.3.1"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-fortify.patch
-}
-
src_install() {
emake DESTDIR="${D}" install || die
dodoc "${S}"/{ChangeLog,NEWS,README,TODO}