summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-03-03 17:45:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-03-03 17:45:26 +0000
commit5ec275752cf2d85f668e1c928a01e41e3a1232da (patch)
treeabe423b52c8baa6c6a85b9670fc060e301d14949 /dev-libs/mini-xml
parentVersion bump (diff)
downloadgentoo-2-5ec275752cf2d85f668e1c928a01e41e3a1232da.tar.gz
gentoo-2-5ec275752cf2d85f668e1c928a01e41e3a1232da.tar.bz2
gentoo-2-5ec275752cf2d85f668e1c928a01e41e3a1232da.zip
Respect CFLAGS/LDFLGAS wrt bug #306165. EAPI2fy
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/mini-xml')
-rw-r--r--dev-libs/mini-xml/ChangeLog8
-rw-r--r--dev-libs/mini-xml/mini-xml-2.6.ebuild25
2 files changed, 19 insertions, 14 deletions
diff --git a/dev-libs/mini-xml/ChangeLog b/dev-libs/mini-xml/ChangeLog
index c626ae32b510..329676193e6d 100644
--- a/dev-libs/mini-xml/ChangeLog
+++ b/dev-libs/mini-xml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/mini-xml
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mini-xml/ChangeLog,v 1.16 2009/10/03 15:10:21 vostorga Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mini-xml/ChangeLog,v 1.17 2010/03/03 17:45:26 hwoarang Exp $
+
+ 03 Mar 2010; Markos Chandras <hwoarang@gentoo.org> mini-xml-2.6.ebuild:
+ Respect CFLAGS/LDFLGAS wrt bug #306165 thanks to Doktor Notor
+ <notordoktor@gmail.com>. EAPI2fy it
*mini-xml-2.6 (03 Oct 2009)
diff --git a/dev-libs/mini-xml/mini-xml-2.6.ebuild b/dev-libs/mini-xml/mini-xml-2.6.ebuild
index e365e2cfe3a6..5ca00d4bb339 100644
--- a/dev-libs/mini-xml/mini-xml-2.6.ebuild
+++ b/dev-libs/mini-xml/mini-xml-2.6.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mini-xml/mini-xml-2.6.ebuild,v 1.1 2009/10/03 15:10:21 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mini-xml/mini-xml-2.6.ebuild,v 1.2 2010/03/03 17:45:26 hwoarang Exp $
+
+EAPI="2"
inherit autotools multilib
MY_P="${P/mini-xml/mxml}"
-DESCRIPTION="Small XML parsing library to read XML and XML-like data files."
+DESCRIPTION="Small XML parsing library to read XML and XML-like data files"
HOMEPAGE="http://www.easysw.com/~mike/mxml"
SRC_URI="mirror://easysw/mxml/${PV}/${MY_P}.tar.gz"
@@ -20,27 +22,26 @@ RDEPEND=""
S="${WORKDIR}/${MY_P}"
-src_test() {
- emake testmxml
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
sed -i -e "s:755 -s:755:" Makefile.in || die "sed failed"
sed -i "/^TARGETS/s: testmxml::" Makefile.in || die "sed failed"
+ sed -i -e 's:$(DSO) $(DSOFLAGS) -o libmxml.so.1.4 $(LIBOBJS):$(DSO) $(DSOFLAGS) $(LDFLAGS) -o libmxml.so.1.4 $(LIBOBJS):' \
+ Makefile.in || die "sed failed"
+ sed -i -e 's:OPTIM="-Os -g":OPTIM="":' configure.in || die "sed failed"
rm configure
# eautoreconf
eautoconf
}
-src_compile() {
+src_configure() {
econf \
--enable-shared \
--libdir="/usr/$(get_libdir)" \
--with-docdir="/usr/share/doc/${PF}/html" \
$(use_enable threads)
+}
+
+src_compile() {
emake libmxml.a libmxml.so.1.4 mxmldoc doc/mxml.man || die "make failed"
}