summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-06 23:19:28 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-06 23:19:28 +0000
commit3e7ff77f9d0178dcb27b1deb31f3d74ff86b6d81 (patch)
tree99094f6ad0cc9e6b274daed244f95e45e0814312 /dev-libs/link-grammar
parentClean up old revision. (diff)
downloadgentoo-2-3e7ff77f9d0178dcb27b1deb31f3d74ff86b6d81.tar.gz
gentoo-2-3e7ff77f9d0178dcb27b1deb31f3d74ff86b6d81.tar.bz2
gentoo-2-3e7ff77f9d0178dcb27b1deb31f3d74ff86b6d81.zip
Clean up old revision.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/link-grammar')
-rw-r--r--dev-libs/link-grammar/ChangeLog8
-rw-r--r--dev-libs/link-grammar/files/link-grammar-4.2.4-tokenize.patch83
-rw-r--r--dev-libs/link-grammar/link-grammar-4.7.4.ebuild52
3 files changed, 6 insertions, 137 deletions
diff --git a/dev-libs/link-grammar/ChangeLog b/dev-libs/link-grammar/ChangeLog
index 83d79f02504f..b5fdf813a888 100644
--- a/dev-libs/link-grammar/ChangeLog
+++ b/dev-libs/link-grammar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/link-grammar
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/ChangeLog,v 1.53 2012/11/30 19:28:09 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/ChangeLog,v 1.54 2013/03/06 23:19:28 eva Exp $
+
+ 06 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ -files/link-grammar-4.2.4-tokenize.patch, -link-grammar-4.7.4.ebuild:
+ Clean up old revision.
30 Nov 2012; Ulrich Müller <ulm@gentoo.org> link-grammar-4.7.4.ebuild,
link-grammar-4.7.6.ebuild, link-grammar-4.7.8.ebuild:
diff --git a/dev-libs/link-grammar/files/link-grammar-4.2.4-tokenize.patch b/dev-libs/link-grammar/files/link-grammar-4.2.4-tokenize.patch
deleted file mode 100644
index 34a9eb0a1c8f..000000000000
--- a/dev-libs/link-grammar/files/link-grammar-4.2.4-tokenize.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-Index: tokenize.c
-===================================================================
-RCS file: /cvsroot/link-grammar/link-grammar/tokenize.c,v
-retrieving revision 1.3
-retrieving revision 1.4
-diff -u -b -B -r1.3 -r1.4
---- link-grammar/link-grammar/tokenize.c 16 Aug 2006 17:07:02 -0000 1.3
-+++ link-grammar/link-grammar/tokenize.c 27 Oct 2007 19:03:40 -0000 1.4
-@@ -172,7 +172,8 @@
- used in a sentence.
- */
-
--
-+#undef MIN
-+#define MIN(a, b) (((a) < (b)) ? (a) : (b))
-
- static int separate_word(Sentence sent, char *w, char *wend, int is_first_word, int quote_found) {
- /* w points to a string, wend points to the char one after the end. The
-@@ -256,8 +257,8 @@
-
- for (n_r_stripped = 0; n_r_stripped < MAX_STRIP; n_r_stripped++) {
-
-- strncpy(word, w, wend-w);
-- word[wend-w] = '\0';
-+ strncpy(word, w, MIN(wend-w, MAX_WORD));
-+ word[MIN(wend-w, MAX_WORD)] = '\0';
- if (wend == w) break; /* it will work without this */
-
- if (boolean_dictionary_lookup(sent->dict, word) || is_initials_word(word)) break;
-@@ -285,8 +286,8 @@
- /* Now we strip off suffixes...w points to the remaining word, "wend" to the end of the word. */
-
- s_stripped = -1;
-- strncpy(word, w, wend-w);
-- word[wend-w] = '\0';
-+ strncpy(word, w, MIN(wend-w, MAX_WORD));
-+ word[MIN(wend-w, MAX_WORD)] = '\0';
- word_is_in_dict=0;
-
- if (boolean_dictionary_lookup(sent->dict, word) || is_initials_word(word)) word_is_in_dict=1;
-@@ -309,16 +310,16 @@
-
- if(s_ok==1 || i==s_strippable) {
-
-- strncpy(newword, w, (wend-len)-w);
-- newword[(wend-len)-w] = '\0';
-+ strncpy(newword, w, MIN((wend-len)-w, MAX_WORD));
-+ newword[MIN((wend-len)-w, MAX_WORD)] = '\0';
-
- /* Check if the remainder is in the dictionary; for the no-suffix case, it won't be */
- if (boolean_dictionary_lookup(sent->dict, newword)) {
- if(verbosity>1) if(i< s_strippable) printf("Splitting word into two: %s-%s\n", newword, suffix[i]);
- s_stripped = i;
- wend -= len;
-- strncpy(word, w, wend-w);
-- word[wend-w] = '\0';
-+ strncpy(word, w, MIN(wend-w, MAX_WORD));
-+ word[MIN(wend-w, MAX_WORD)] = '\0';
- break;
- }
-
-@@ -326,16 +327,16 @@
- else {
- for (j=0; j<p_strippable; j++) {
- if (strncmp(w, prefix[j], strlen(prefix[j])) == 0) {
-- strncpy(newword, w+strlen(prefix[j]), (wend-len)-(w+strlen(prefix[j])));
-- newword[(wend-len)-(w+strlen(prefix[j]))]='\0';
-+ strncpy(newword, w+strlen(prefix[j]), MIN((wend-len)-(w+strlen(prefix[j])), MAX_WORD));
-+ newword[MIN((wend-len)-(w+strlen(prefix[j])), MAX_WORD)]='\0';
- if(boolean_dictionary_lookup(sent->dict, newword)) {
- if(verbosity>1) if(i < s_strippable) printf("Splitting word into three: %s-%s-%s\n", prefix[j], newword, suffix[i]);
- if (!issue_sentence_word(sent, prefix[j])) return FALSE;
- if(i < s_strippable) s_stripped = i;
- wend -= len;
- w += strlen(prefix[j]);
-- strncpy(word, w, wend-w);
-- word[wend-w] = '\0';
-+ strncpy(word, w, MIN(wend-w, MAX_WORD));
-+ word[MIN(wend-w, MAX_WORD)] = '\0';
- break;
- }
- }
-
diff --git a/dev-libs/link-grammar/link-grammar-4.7.4.ebuild b/dev-libs/link-grammar/link-grammar-4.7.4.ebuild
deleted file mode 100644
index ea081bc2dad5..000000000000
--- a/dev-libs/link-grammar/link-grammar-4.7.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/link-grammar-4.7.4.ebuild,v 1.7 2012/11/30 19:28:09 ulm Exp $
-
-EAPI="3"
-
-inherit java-pkg-opt-2
-
-DESCRIPTION="Link Grammar Parser is a syntactic English parser based on
-link grammar."
-HOMEPAGE="http://www.abisource.com/projects/link-grammar/ http://www.link.cs.cmu.edu/link/"
-SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-
-# Set the same default as used in app-text/enchant
-IUSE="aspell +hunspell java static-libs threads"
-
-DEPEND="aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell )
- java? ( >=virtual/jdk-1.5 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
- if use aspell && use hunspell; then
- ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
- ewarn "only aspell will be build. Press Ctrl+C and set only 'hunspell' USE flag if"
- ewarn "you want hunspell support."
- fi
-}
-
-src_configure() {
- local myconf
-
- use hunspell && myconf="${myconf} --with-hunspell-dictdir=/usr/share/myspell"
- econf \
- --enable-shared \
- $(use_enable aspell) \
- $(use_enable hunspell) \
- $(use_enable java java-bindings) \
- $(use_enable static-libs static) \
- $(use_enable threads pthreads) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog README || die
-}