summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-08 14:29:38 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-08 14:29:38 +0000
commitbba1989f521d2edb154f403c94da820cebd275fb (patch)
treec5739e73cb8285ba816adcf109d9b44387eb1a3b /dev-libs/libxml
parentarm KEYWORDS (Manifest recommit) (diff)
downloadgentoo-2-bba1989f521d2edb154f403c94da820cebd275fb.tar.gz
gentoo-2-bba1989f521d2edb154f403c94da820cebd275fb.tar.bz2
gentoo-2-bba1989f521d2edb154f403c94da820cebd275fb.zip
arm KEYWORDS
Diffstat (limited to 'dev-libs/libxml')
-rw-r--r--dev-libs/libxml/libxml-1.8.17-r2.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-libs/libxml/libxml-1.8.17-r2.ebuild b/dev-libs/libxml/libxml-1.8.17-r2.ebuild
index a14e61fadcf3..f623e4e0ee34 100644
--- a/dev-libs/libxml/libxml-1.8.17-r2.ebuild
+++ b/dev-libs/libxml/libxml-1.8.17-r2.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/libxml-1.8.17-r2.ebuild,v 1.24 2004/07/29 03:37:59 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/libxml-1.8.17-r2.ebuild,v 1.25 2004/11/08 14:29:19 vapier Exp $
-DESCRIPTION="Version 1 of the library to manipulate XML files."
-SRC_URI="ftp://xmlsoft.org/old/${P}.tar.gz"
+inherit flag-o-matic
+
+DESCRIPTION="Version 1 of the library to manipulate XML files"
HOMEPAGE="http://www.xmlsoft.org/"
+SRC_URI="ftp://xmlsoft.org/old/${P}.tar.gz"
-SLOT="1"
LICENSE="GPL-2 LGPL-2"
-KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64 mips ppc64"
+SLOT="1"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
IUSE=""
RDEPEND=">=sys-libs/ncurses-5.2"
@@ -17,9 +19,9 @@ DEPEND="${RDEPEND}
>=sys-libs/readline-4.1"
src_compile() {
- LDFLAGS="-lncurses" econf || die
-
- make || die # Doesn't work with -j 4 (hallski)
+ append-ldflags -lncurses
+ econf || die
+ emake -j1 || die # Doesn't work with -j 4 (hallski)
}
src_install() {
@@ -33,7 +35,7 @@ src_install() {
rm ${D}/usr/include/gnome-xml/libxml
dosym /usr/include/gnome-xml /usr/include/gnome-xml/libxml
- dodoc AUTHORS COPYING* ChangeLog NEWS README
+ dodoc AUTHORS ChangeLog NEWS README
}
pkg_preinst() {