summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-05-14 20:20:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-05-14 20:20:21 +0000
commit7444394752983f668828f24127edafdbcb505464 (patch)
treef3fa1d04119dad2c17f1d27fe1047a25079baa65 /dev-libs/libsigc++
parentVersion bump. Replace usage of berkdb by libgda. Misc bugfixes and translatio... (diff)
downloadgentoo-2-7444394752983f668828f24127edafdbcb505464.tar.gz
gentoo-2-7444394752983f668828f24127edafdbcb505464.tar.bz2
gentoo-2-7444394752983f668828f24127edafdbcb505464.zip
Version bump. Updated documentation and cleaned up tutorial.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libsigc++')
-rw-r--r--dev-libs/libsigc++/ChangeLog8
-rw-r--r--dev-libs/libsigc++/libsigc++-2.2.7.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-libs/libsigc++/ChangeLog b/dev-libs/libsigc++/ChangeLog
index 179356696fc9..a3c218d45bb6 100644
--- a/dev-libs/libsigc++/ChangeLog
+++ b/dev-libs/libsigc++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libsigc++
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.148 2010/04/19 20:22:59 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.149 2010/05/14 20:20:21 eva Exp $
+
+*libsigc++-2.2.7 (14 May 2010)
+
+ 14 May 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +libsigc++-2.2.7.ebuild:
+ Version bump. Updated documentation and cleaned up tutorial.
*libsigc++-2.2.6 (19 Apr 2010)
diff --git a/dev-libs/libsigc++/libsigc++-2.2.7.ebuild b/dev-libs/libsigc++/libsigc++-2.2.7.ebuild
new file mode 100644
index 000000000000..7a3e68ed8cf6
--- /dev/null
+++ b/dev-libs/libsigc++/libsigc++-2.2.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.2.7.ebuild,v 1.1 2010/05/14 20:20:21 eva Exp $
+
+EAPI="3"
+
+inherit base eutils gnome.org flag-o-matic
+
+DESCRIPTION="Typesafe callback system for standard C++"
+HOMEPAGE="http://libsigc.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+# Needs mm-common for eautoreconf
+src_prepare() {
+ # don't waste time building examples
+ sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' \
+ Makefile.am Makefile.in || die "sed examples failed"
+
+ # don't waste time building tests unless USE=test
+ if ! use test ; then
+ sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' \
+ Makefile.am Makefile.in || die "sed tests failed"
+ fi
+}
+
+src_configure() {
+ filter-flags -fno-exceptions
+
+ local myconf="$myconf $(use_enable doc documentation)"
+
+ econf ${myconf} || die "econf failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed."
+ dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/* || die "dohtml failed"
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "To allow parallel installation of sigc++-1.0, sigc++-1.2, and sigc++2.0"
+ ewarn "the header files are now installed in a version specific"
+ ewarn "subdirectory. Be sure to unmerge any libsigc++ versions"
+ ewarn "< 1.0.4 that you may have previously installed."
+}