summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-02-17 22:10:25 +0000
committerAron Griffis <agriffis@gentoo.org>2006-02-17 22:10:25 +0000
commit755a52b08217b2781bf322e0b9ed4da9690aa47e (patch)
tree38248e29dab1e6ad0621ea785c9e6051a7acffac /dev-libs/librep
parentVersion bump. (diff)
downloadgentoo-2-755a52b08217b2781bf322e0b9ed4da9690aa47e.tar.gz
gentoo-2-755a52b08217b2781bf322e0b9ed4da9690aa47e.tar.bz2
gentoo-2-755a52b08217b2781bf322e0b9ed4da9690aa47e.zip
Add gcc-4 fix, mark stable on ia64
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-libs/librep')
-rw-r--r--dev-libs/librep/ChangeLog5
-rw-r--r--dev-libs/librep/librep-0.17-r2.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-libs/librep/ChangeLog b/dev-libs/librep/ChangeLog
index a2499b8ae7c8..37a8de60464b 100644
--- a/dev-libs/librep/ChangeLog
+++ b/dev-libs/librep/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/librep
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.37 2006/01/17 00:47:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.38 2006/02/17 22:10:25 agriffis Exp $
+
+ 17 Feb 2006; Aron Griffis <agriffis@gentoo.org> librep-0.17-r2.ebuild:
+ Add gcc-4 fix, mark stable on ia64
17 Jan 2006; Aron Griffis <agriffis@gentoo.org>
-files/librep-0.15.2-exec.patch:
diff --git a/dev-libs/librep/librep-0.17-r2.ebuild b/dev-libs/librep/librep-0.17-r2.ebuild
index 9d9eca239ad9..a34aa09c0824 100644
--- a/dev-libs/librep/librep-0.17-r2.ebuild
+++ b/dev-libs/librep/librep-0.17-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17-r2.ebuild,v 1.5 2005/11/14 07:56:59 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17-r2.ebuild,v 1.6 2006/02/17 22:10:25 agriffis Exp $
inherit eutils libtool toolchain-funcs multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ia64 ~ppc ~sparc ~x86"
IUSE="readline"
RDEPEND=">=sys-libs/gdbm-1.8.0
@@ -32,6 +32,11 @@ src_compile() {
local myconf="$(use_with readline)"
use ppc && myconf="${myconf} --with-stack-direction=1"
+ # It seems that stack-direction=-1 for gcc-3.x and 1 for gcc-4.x on ia64
+ if use ia64 && [[ $(gcc-major-version) -ge 4 ]]; then
+ myconf="${myconf} --with-stack-direction=1"
+ fi
+
econf \
--libexecdir=/usr/$(get_libdir) \
--without-gmp \