summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2005-09-01 19:20:34 +0000
committerHarald van Dijk <truedfx@gentoo.org>2005-09-01 19:20:34 +0000
commit41be6b878120767be7a2668687f116cdcdea7a61 (patch)
tree348d313ba4da39869730804d7f0ebb22fac37d8a /dev-libs/librep/librep-0.17-r2.ebuild
parentKeyworded sparc stable and -sparc (diff)
downloadgentoo-2-41be6b878120767be7a2668687f116cdcdea7a61.tar.gz
gentoo-2-41be6b878120767be7a2668687f116cdcdea7a61.tar.bz2
gentoo-2-41be6b878120767be7a2668687f116cdcdea7a61.zip
many cleanups and fixes
(Portage version: 1.589-cvs)
Diffstat (limited to 'dev-libs/librep/librep-0.17-r2.ebuild')
-rw-r--r--dev-libs/librep/librep-0.17-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/librep/librep-0.17-r2.ebuild b/dev-libs/librep/librep-0.17-r2.ebuild
new file mode 100644
index 000000000000..e732023e0973
--- /dev/null
+++ b/dev-libs/librep/librep-0.17-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17-r2.ebuild,v 1.1 2005/09/01 19:20:34 truedfx Exp $
+
+inherit libtool toolchain-funcs multilib
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+HOMEPAGE="http://librep.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="readline"
+
+RDEPEND="sys-devel/libtool
+ >=sys-libs/gdbm-1.8.0
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '7s/AM_PATH_REP/[&]/' rep.m4 || die "sed failed"
+ elibtoolize || die "elibtoolize failed"
+}
+
+src_compile() {
+ local myconf="$(use_with readline)"
+ use ppc && myconf="${myconf} --with-stack-direction=1"
+
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ --without-gmp \
+ --without-ffi \
+ ${myconf} || die "configure failed"
+
+ LC_ALL=C emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dosym ../../../bin/libtool /usr/$(get_libdir)/rep/${CHOST}/libtool
+ fowners -h root:0 /usr/$(get_libdir)/rep/${CHOST}/libtool
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO TREE
+ docinto doc
+ dodoc doc/*
+}