summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-09-04 04:00:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-09-04 04:00:39 +0000
commiteaed907262838e2455a6ab321e29d79d8b5ba3df (patch)
treef4a0bb7cd0c919e7c18f70c978a4af96a72879b0 /dev-libs/libmemcached/libmemcached-0.50.ebuild
parentBug #381737: block dev-libs/libmemcached[tcmalloc] until dev-utils/google-per... (diff)
downloadgentoo-2-eaed907262838e2455a6ab321e29d79d8b5ba3df.tar.gz
gentoo-2-eaed907262838e2455a6ab321e29d79d8b5ba3df.tar.bz2
gentoo-2-eaed907262838e2455a6ab321e29d79d8b5ba3df.zip
Bug #354261: version bump, despite my objections. Please report any testcase failures, but see bug #354261 first.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libmemcached/libmemcached-0.50.ebuild')
-rw-r--r--dev-libs/libmemcached/libmemcached-0.50.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/libmemcached/libmemcached-0.50.ebuild b/dev-libs/libmemcached/libmemcached-0.50.ebuild
new file mode 100644
index 000000000000..e97e05479b05
--- /dev/null
+++ b/dev-libs/libmemcached/libmemcached-0.50.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-0.50.ebuild,v 1.1 2011/09/04 04:00:39 robbat2 Exp $
+
+EAPI="3"
+
+inherit eutils multilib
+
+DESCRIPTION="a C client library to the memcached server"
+HOMEPAGE="http://tangent.org/552/libmemcached.html"
+SRC_URI="http://launchpad.net/${PN}/1.0/${PV}/+download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc hsieh +libevent sasl static-libs tcmalloc"
+
+DEPEND="net-misc/memcached
+ virtual/perl-PodParser
+ doc? ( dev-python/sphinx )
+ libevent? ( dev-libs/libevent )
+ tcmalloc? ( dev-util/google-perftools )
+ sasl? ( virtual/gsasl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # These tests freezes for me
+ sed -i -e "/connectionpool/d" \
+ -e "/lp:583031/d" tests/mem_functions.cc || die
+}
+
+src_configure() {
+ econf \
+ --disable-dtrace \
+ --disable-libinnodb \
+ $(use_enable debug assert) \
+ $(use_with debug debug) \
+ $(use_enable hsieh hsieh_hash) \
+ $(use_enable libevent libevent) \
+ $(use_enable tcmalloc tcmalloc) \
+ $(use_with sasl libsasl-prefix) \
+ $(use_with sasl libsasl2-prefix) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake || die
+
+ if use doc; then
+ emake html-local || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib*.la
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+ # remove manpage to avoid collision, see bug #299330
+ rm -f "${D}"/usr/share/man/man1/memdump.* || die "Install failed"
+ newman docs/man/memdump.1 memcached_memdump.1
+ if use doc; then
+ dohtml -r docs/html/* || die
+ fi
+}