summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 15:51:18 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 15:51:18 +0000
commit6b61949f823a9c93d4c42f5451192b7c0a1f8b83 (patch)
tree5c10172cde2cbf32ea733b172ae17737c0852c4f /dev-libs/libhome
parentFix whitespace. (diff)
downloadgentoo-2-6b61949f823a9c93d4c42f5451192b7c0a1f8b83.tar.gz
gentoo-2-6b61949f823a9c93d4c42f5451192b7c0a1f8b83.tar.bz2
gentoo-2-6b61949f823a9c93d4c42f5451192b7c0a1f8b83.zip
Add a patch to fix bug #225579. Yes you can shoot yourself in the foot with autotools doing crazy stuff.
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-libs/libhome')
-rw-r--r--dev-libs/libhome/ChangeLog7
-rw-r--r--dev-libs/libhome/files/libhome-0.10.1-fixlt.patch16
-rw-r--r--dev-libs/libhome/libhome-0.10.1.ebuild3
3 files changed, 24 insertions, 2 deletions
diff --git a/dev-libs/libhome/ChangeLog b/dev-libs/libhome/ChangeLog
index 69ee25600c08..4d09f6b1d363 100644
--- a/dev-libs/libhome/ChangeLog
+++ b/dev-libs/libhome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libhome
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/ChangeLog,v 1.5 2008/06/01 12:53:13 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/ChangeLog,v 1.6 2008/06/09 15:51:18 flameeyes Exp $
+
+ 09 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libhome-0.10.1-fixlt.patch, libhome-0.10.1.ebuild:
+ Add a patch to fix bug #225579. Yes you can shoot yourself in the foot
+ with autotools doing crazy stuff.
01 Jun 2008; Benedikt Böhm <hollow@gentoo.org> libhome-0.10.1.ebuild:
fix #220887
diff --git a/dev-libs/libhome/files/libhome-0.10.1-fixlt.patch b/dev-libs/libhome/files/libhome-0.10.1-fixlt.patch
new file mode 100644
index 000000000000..efda0bb3b35a
--- /dev/null
+++ b/dev-libs/libhome/files/libhome-0.10.1-fixlt.patch
@@ -0,0 +1,16 @@
+Index: libhome-0.10.1/configure.in
+===================================================================
+--- libhome-0.10.1.orig/configure.in
++++ libhome-0.10.1/configure.in
+@@ -21,9 +21,9 @@ dnl USA
+ dnl $Id: libhome-0.10.1-fixlt.patch,v 1.1 2008/06/09 15:51:18 flameeyes Exp $
+ dnl Process this file with autoconf to produce a configure script.
+
+-define(VERSION, esyscmd([awk '{printf "%s", $0}' VERSION]))
++define(__PKG_VERSION, esyscmd([awk '{printf "%s", $0}' VERSION]))
+
+-AC_INIT(libhome, VERSION, lwa@teaser.fr)
++AC_INIT(libhome, __PKG_VERSION, lwa@teaser.fr)
+ AC_REVISION($Revision: 1.1 $)
+ AC_CONFIG_HEADER(config.h)
+ AC_PREREQ(2.53)
diff --git a/dev-libs/libhome/libhome-0.10.1.ebuild b/dev-libs/libhome/libhome-0.10.1.ebuild
index dc7039e7ec01..78d7591f5b92 100644
--- a/dev-libs/libhome/libhome-0.10.1.ebuild
+++ b/dev-libs/libhome/libhome-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/libhome-0.10.1.ebuild,v 1.4 2008/06/01 12:53:13 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/libhome-0.10.1.ebuild,v 1.5 2008/06/09 15:51:18 flameeyes Exp $
inherit autotools db-use eutils
@@ -25,6 +25,7 @@ src_unpack() {
cd "${S}"
rm -f aclocal.m4
epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${P}-fixlt.patch
eautoreconf
}