summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-27 03:42:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-27 03:42:55 +0000
commita3c4680a32875cf800002d13d3a234adfa9208db (patch)
tree0769168372404e3343f79d4f31e015e6b0657168 /dev-libs/libhash/libhash-1.0.2.ebuild
parentfix typo and make sure uclibc installs the sys-include link for gcc (diff)
downloadgentoo-2-a3c4680a32875cf800002d13d3a234adfa9208db.tar.gz
gentoo-2-a3c4680a32875cf800002d13d3a234adfa9208db.tar.bz2
gentoo-2-a3c4680a32875cf800002d13d3a234adfa9208db.zip
amd64/arm/hppa/ia64 KEYWORDS
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-libs/libhash/libhash-1.0.2.ebuild')
-rw-r--r--dev-libs/libhash/libhash-1.0.2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-libs/libhash/libhash-1.0.2.ebuild b/dev-libs/libhash/libhash-1.0.2.ebuild
index d558b8b00697..aadb15e4d9cc 100644
--- a/dev-libs/libhash/libhash-1.0.2.ebuild
+++ b/dev-libs/libhash/libhash-1.0.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhash/libhash-1.0.2.ebuild,v 1.2 2004/07/17 09:35:17 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhash/libhash-1.0.2.ebuild,v 1.3 2005/01/27 03:42:55 vapier Exp $
-inherit gcc
+inherit toolchain-funcs
DESCRIPTION="a small hash library written in C"
HOMEPAGE="ftp://ftp.ugh.net.au/pub/unix/libhash/"
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.ugh.net.au/pub/unix/libhash/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="amd64 arm hppa ia64 ppc x86"
IUSE="doc"
DEPEND="virtual/libc"
@@ -19,8 +19,8 @@ S=${WORKDIR}/${PN}
src_compile() {
rm -f Makefile
- $(gcc-getCC) ${CFLAGS} -fPIC -shared -o libhash.so hash.c || die ".so failed"
- $(gcc-getCC) ${CFLAGS} -c -o libhash.a hash.c || die ".a failed"
+ $(tc-getCC) ${CFLAGS} -fPIC -shared -o libhash.so hash.c || die ".so failed"
+ $(tcc-getCC) ${CFLAGS} -c -o libhash.a hash.c || die ".a failed"
}
src_install() {