summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:02:39 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:02:39 +0000
commit10a102ec8ff3f11500cdf945f68631d3f3490719 (patch)
tree428654f340215726d1e105ddf6db044b4aa4eecc /dev-libs/libgcrypt
parentJaxp was a repack of various apache projects under a very restrictive Sun lic... (diff)
downloadgentoo-2-10a102ec8ff3f11500cdf945f68631d3f3490719.tar.gz
gentoo-2-10a102ec8ff3f11500cdf945f68631d3f3490719.tar.bz2
gentoo-2-10a102ec8ff3f11500cdf945f68631d3f3490719.zip
repoman'd
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild b/dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild
index 82742ad19a95..9175b18aae36 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild
@@ -1,26 +1,29 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild,v 1.4 2002/08/01 18:02:36 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="libgcrypt is a general purpose crypto library based on the code used in GnuPG."
SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/${P}.tar.gz"
HOMEPAGE="http://www.gnupg.org"
-DEPEND="virtual/glibc
- app-text/jadetex
- app-text/docbook2X
- nls? ( sys-devel/gettext )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="app-text/jadetex
+ app-text/docbook2X"
+
+RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
local myconf
use nls || myconf="${myconf} --disable-nls"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --host=${CHOST} \
- --enable-m-guard \
- --enable-static \
+
+ econf \
+ --enable-m-guard \
+ --enable-static \
${myconf} || die
emake || die
@@ -29,6 +32,5 @@ src_compile() {
src_install () {
make DESTDIR=${D} install || die
-
dodoc AUTHORS BUGS COPYING INSTALL NEWS README* THANKS VERSION
}