summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2004-01-01 16:22:26 +0000
committerHanno Böck <hanno@gentoo.org>2004-01-01 16:22:26 +0000
commit88ee88e5aec118d58f76efc7581d0b89106b7661 (patch)
tree9a4766ce2e8b0ed9e177fa0b46419b0e5e219074 /dev-libs/libgcrypt/libgcrypt-1.1.91.ebuild
parentcleanup (diff)
downloadgentoo-2-88ee88e5aec118d58f76efc7581d0b89106b7661.tar.gz
gentoo-2-88ee88e5aec118d58f76efc7581d0b89106b7661.tar.bz2
gentoo-2-88ee88e5aec118d58f76efc7581d0b89106b7661.zip
libgcrypt version bump
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.1.91.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.1.91.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.1.91.ebuild b/dev-libs/libgcrypt/libgcrypt-1.1.91.ebuild
new file mode 100644
index 000000000000..b664d22c0c24
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.1.91.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.1.91.ebuild,v 1.1 2004/01/01 16:22:26 hanno Exp $
+
+DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc nls"
+
+DEPEND="dev-libs/libgpg-error"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls) --disable-dependency-tracking || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog COPYING* NEWS README* THANKS TODO VERSION
+}